Opened 4 years ago

Closed 4 years ago

#2047 closed defect (invalid)

svn trunk does not built with gcc-4.7 prereleases

Reported by: belegdol+mplayer@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc: compn, ojab@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

I have recently tried to update mplayer rpm package in RPM fusion to the latest SVN. Unfortunately, it does not build with gcc-4.7 prereleases Fedora switched to. I originally reported this to ffmpeg [1], but the bug turned out to belong to mplayer:

ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `encode_init':
/builddir/build/BUILD/mplayer-export-2012-02-26/ffmpeg/libavcodec/ffv1.c:1041: undefined reference to `builtin_iround'
collect2: error: ld returned 1 exit status
make: * [mencoder] Error 1
make:
* Waiting for unfinished jobs....
ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `encode_init':
/builddir/build/BUILD/mplayer-export-2012-02-26/ffmpeg/libavcodec/ffv1.c:1041: undefined reference to `
builtin_iround'
collect2: error: ld returned 1 exit status
make: * [mplayer] Error 1

Full build log is attached.

[1] https://ffmpeg.org/trac/ffmpeg/ticket/1024

Attachments (1)

build.log.xz (76.9 KB) - added by belegdol+mplayer@… 4 years ago.
full build log

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by belegdol+mplayer@…

full build log

comment:1 Changed 4 years ago by belegdol+mplayer@…

comment:2 Changed 4 years ago by compn

  • Cc patriotact@… added

could you try gcc 4.7 from gcc and not distro version?

(yes, we are playing hot potato with this bug)

comment:3 Changed 4 years ago by belegdol+mplayer@…

Hmm, I don't know. I need to remind myself how does one bootstrap a compiler. I'll report back once I figure it out.

comment:4 Changed 4 years ago by ojab@…

  • Cc ojab@… added

The same error with
gcc (GCC) 4.7.0 20120302 (prerelease)
on LFS system (so gcc was built from source).

comment:5 Changed 4 years ago by ojab@…

(to be exact):
gcc -o mplayer command.o m_property.o mixer.o mp_fifo.o …
ffmpeg/libavcodec/libavcodec.a(ffv1.o): In function `encode_init':
ffv1.c:(.text.unlikely+0x1679): undefined reference to `builtin_iround'
collect2: error: ld returned 1 exit status
make: * [mplayer] Error 1

comment:6 Changed 4 years ago by ojab@…

Looks like related to http://gcc.gnu.org/ml/gcc-patches/2011-08/msg01001.html and

Please document those in doc/extend.texi and make sure they do not leak into the global namespace as ifloor, etc., but are only available as builtin_ifloor, etc..

from http://gcc.gnu.org/ml/gcc-patches/2011-08/msg01003.html

mplayer builds fine with CFLAGS=-ffast-math, looks like gcc bug (I'm not a programmer, though).

comment:8 Changed 4 years ago by ojab@…

  • Resolution set to invalid
  • Status changed from new to closed

Fixed in GCC.

Note: See TracTickets for help on using tickets.