Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2077 closed defect (invalid)

broken playback with ffmpeg zerocodec decoder

Reported by: onemda@… Owned by: reimar
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer is unable to correctly play avi files with zerocodec video codec.

Change History (6)

comment:1 Changed 7 years ago by compn

  • Cc patriotact@… added

try adding this to your codecs.conf
i dont have a sample to test.

videocodec ffzerocodec

info "FFmpeg Zerocodec lossless"
status working
fourcc ZECO
driver ffmpeg
dll "zerocodec"
out UYVY

comment:2 Changed 7 years ago by onemda@…

I already have that line and it does not help.

Sample: http://samples.ffmpeg.org/V-codecs/ZECO/

comment:3 Changed 7 years ago by reimar

I'll have to test it, but I believe that if you use the old-style DR system (i.e. not setting buffer flags) you need to set the picture type before calling get_buffer.

comment:4 Changed 7 years ago by reimar

Didn't help, though it is a good idea since the (!prev) check can otherwise cause a leak (i.e. get_buffer being called without a corresponding release_buffer)

comment:5 Changed 7 years ago by onemda@…

  • Resolution set to invalid
  • Status changed from new to closed

This is lavc bug, sorry for the noise.

comment:6 Changed 7 years ago by reimar

Well, there is a MPlayer bug as well (now fixed), but the issue here seems to be that data[0] is not NULL when get_buffer is called.

Note: See TracTickets for help on using tickets.