Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#337 closed defect (worksforme)

configure not verbose with k8 processors

Reported by: stranche@… Owned by: alex@…
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

when issuing the ./configure command, the output is much more verbose on Intel
based CPUs (tested on Opteron, P4 and P3), the GCC version isn't the concern the
same distro on a P4 produced the same kind of difference.

Here's the lines on a Opteron and P3 system (I couldn't get the output of the P4
at hand) :

Opteron
Detected operating system: Linux
Detected host architecture: x86_64
Checking for cc version ... 4.0.0, ok
Checking for host cc ... cc
Checking for GCC & CPU optimization abilities ... k8
Checking for assembler support of -pipe option ... yes
Checking for mplayer binary name ... mplayer

P3
Detected operating system: Linux
Detected host architecture: i386
Checking for cc version ... 3.4.3, ok
Checking for host cc ... cc
Checking for CPU vendor ... GenuineIntel? (6:8:3)
Checking for CPU type ... Pentium III (Coppermine)
Checking for GCC & CPU optimization abilities ... pentium3
Checking for kernel support of mmx ... yes
Checking for kernel support of mmx2 ... yes
Checking for kernel support of sse ... yes
Checking for mtrr support ... yes
Checking for assembler support of -pipe option ... yes
Checking for assembler (as 2.15.92.0.2) ... ok
Checking for Linux kernel version ... 2.6.10-1.770_FC3, ok
Checking for mplayer binary name ... mplayer
Checking for awk ... gawk

The rest is identical.

Change History (1)

comment:1 Changed 15 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

There simply is no reason to detect these things since it makes zero difference
for MPlayer, the 64bit instruction sets are all the same (except for details
that do not matter for us).

Note: See TracTickets for help on using tickets.