Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#6 closed defect (invalid)

blinking blue/green/purple line at bottom of XV fullscreen

Reported by: sebastianp@… Owned by: beastd
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc: dominik@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

"-vo x11 -zoom" works fine,
"-vo xv" don't

distro: KNOPPIX_V3.4-2004-05-17-EN

$ uname -a
Linux Knoppix 2.4.26 #1 SMP Sa Apr 17 19:33:42 CEST 2004 i686 GNU/Linux

$ ls -l /lib/libc[.-]*
-rw-r--r-- 1 root root 1243792 2004-04-21 20:58 /lib/libc-2.3.2.so
lrwxrwxrwx 1 root root 13 2004-05-02 02:56 /lib/libc.so.6 ->
libc-2.3.2.so

$ gcc -v
Reading specs from /KNOPPIX/usr/bin/../lib/gcc-lib/i486-linux/3.3.3/specs
Configured with: ../src/configure -v
--enable-languages=c,c++,java,f77,pascal,objc,ada,treelang --prefix=/usr
--mandir=/usr/share/man --infodir=/usr/share/info
--with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared --with-system-zlib
--enable-nls --without-included-gettext --enable-cxa_atexit
--enable-clocale=gnu --enable-debug --enable-java-gc=boehm
--enable-java-awt=xlib --enable-objc-gc i486-linux
Thread model: posix
gcc version 3.3.3 (Debian 20040429)

$ ld -v
GNU ld version 2.14.90.0.7 20031029 Debian GNU/Linux

$ as --version
GNU assembler 2.14.90.0.7 20031029 Debian GNU/Linux
Copyright 2002 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License. This program has absolutely no warranty.
This assembler was configured for a target of `i386-linux'.

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel?
cpu family : 6
model : 8
model name : Celeron (Coppermine)
stepping : 10
cpu MHz : 801.834
cache size : 128 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 mmx fxsr sse

lspci -vv

0000:01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)
(prog-if 00 [VGA])

Subsystem: 3Dfx Interactive, Inc. Voodoo3 AGP
Control: I/O+ Mem+ BusMaster?- SpecCycle?- MemWINV- VGASnoop- ParErr?-

Stepping- SERR- FastB2B-

Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr?- DEVSEL=fast >TAbort- <TAbort-

<MAbort- >SERR- <PERR+

Interrupt: pin A routed to IRQ 11
Region 0: Memory at de000000 (32-bit, non-prefetchable) [size=32M]
Region 1: Memory at e2000000 (32-bit, prefetchable) [size=32M]
Region 2: I/O ports at d800 [size=256]
Expansion ROM at e1ff0000 [disabled] [size=64K]
Capabilities: [54] AGP version 1.0

Status: RQ=8 Iso- ArqSz?=0 Cal=0 SBA+ ITACoh- GART64- HTrans-

64bit+ FW- AGP3- Rate=x1,x2

Command: RQ=1 ArqSz?=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>

Capabilities: [60] Power Management version 1

Flags: PMEClk- DSI+ D1- D2- AuxCurrent?=0mA

PME(D0-,D1-,D2-,D3hot-,D3cold-)

Status: D0 PME-Enable- DSel=0 DScale=0 PME-

kde 3.2.2-1
x11 4.3.0.dfsg.1-1

(II) Module tdfx: vendor="The XFree86 Project"

compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6

(II) TDFX(0): Softbooting the board (through the int10 interface).
(II) TDFX(0): Primary V_BIOS segment is: 0xc000
(II) TDFX(0): Softbooting the board succeeded.
(II) TDFX(0): TDFXFindChips: found 1 chip(s)
() TDFX(0): Depth 16, (--) framebuffer bpp 16
(==) TDFX(0): RGB weight 565
(==) TDFX(0): Default visual is TrueColor?
(--) TDFX(0): Chipset: "3dfx Voodoo3"
(--) TDFX(0): Linear framebuffer at 0xE2000000
(--) TDFX(0): MMIO registers at addr 0xDE000000
(--) TDFX(0): PIO registers at addr 0xD800
(II) TDFX(0): DRAMINIT1 read 0x40530031, programming 0x40202031 (not Banshee)
(II) TDFX(0): TDFXInitChips: numchips = 1
(II) TDFX(0): TDFXInitChips: cfgbits = 0x00000000, initbits = 0x00000001
(II) TDFX(0): TDFXInitChips: mem0base = 0xde000000, mem1base = 0xe2000008
(II) TDFX(0): TDFXInitChips: mem0size = 0x02000000, mem1size = 0x02000000
(II) TDFX(0): TDFXInitChips: mem0bits = 0x00000005, mem1bits = 0x00000050
(II) TDFX(0): TDFXInitChips: cfgbits = 0x00000055
(II) TDFX(0): TDFXInitChips: MMIOAddr[0] = 0xde000000
(II) TDFX(0): TDFXInitChips: LinearAddr?[0] = 0xe2000008
(--) TDFX(0): VideoRAM: 16384 kByte Mapping 32768 kByte
(==) TDFX(0): Using gamma correction (1.0, 1.0, 1.0)

my wish: not a xfree driver bug

Change History (7)

comment:1 Changed 15 years ago by reimar

comment:2 Changed 15 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

No reply since almost a month, so I close this. Feel free to reopen...

comment:3 Changed 15 years ago by sebastianp@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

sorry for late response
host is now knoppix 3.6 (http://distrowatch.com/table.php?distribution=knoppix
for compiler and xfree version)

MPlayer-20041109 and still the same garbage at bottom of screen

also found another display corruption (under xv)
first column form right of fullscreen video contain data copied from 16th (may
be wrong) column
copy is not perfect, this column contains additional garbage (horizontal lines)
width of copied column is related to width of source video - smaller resolution
means bigger last column

comment:4 Changed 14 years ago by mplayer@…

This "blinking blue/green/purple line at bottom of XV fullscreen" artifact has
always been present on my machines that have 3dfx graphics cards in them, but on
none of my machines that have other types of graphic cards. I am thinking this
may either be a bug in the overlay support of the 3dfx cards themselves, or in
the XFree86 tdfx video driver.

comment:5 Changed 13 years ago by diego@…

  • Owner changed from moritz@… to beastd
  • Status changed from reopened to new

comment:6 Changed 13 years ago by dominik@…

  • Cc dominik@… added

Please retry with current MPlayer CVS and latest xorg.

comment:7 Changed 13 years ago by beastd

  • Resolution set to invalid
  • Status changed from new to closed

These were AFAIK driver bugs. Please reopen if I am wrong.

Note: See TracTickets for help on using tickets.