Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#695 closed defect (fixed)

Cannot play theora inside MKV

Reported by: hannes.hauswedell+bugzilla@… Owned by: beastd
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

matroska files containing theora video streams cannot be played...
i found this thread on the mailinglist concerning the issue:
http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2006-September/046131.html

i understand little of video-codec and mplayer internals, but can you not make it work "somehow"?

matroska is really great, and i have encoded many movies to vorbis+theora+mkv.

but i cant play them :(

thank you very much!

Change History (5)

comment:1 Changed 9 years ago by hannes.hauswedell+bugzilla@…

  • op_sys changed from FreeBSD to All
  • rep_platform changed from PC (x86) to All

vlc has support for playing theora inside matroska in svn.
this is the patch: http://trac.videolan.org/vlc/changeset/18468

maybe that helps solving the issue in mplayer.

thank you very much

comment:2 Changed 9 years ago by compn

  • Component changed from vo to demuxer
  • Priority changed from important to normal
  • Version changed from unspecified to HEAD

mplayer -demuxer lavf theora.mkv
now works...

comment:3 Changed 9 years ago by compn

  • Cc diego@… added

* Bug 820 has been marked as a duplicate of this bug. *

comment:4 Changed 9 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

reimar fixed this in svn
if you have a sample that does not work, please upload it and make a new bugzilla.

comment:5 Changed 9 years ago by hannes.hauswedell+bugzilla@…

havent had the chance to test the patches yet (no time to get involved in svn builidng righ tnow), but i'll just hope it works and let you know as soon as the next version including the patches is released!
thank you very much!

Note: See TracTickets for help on using tickets.