Opened 11 years ago

Closed 10 years ago

#1014 closed defect (duplicate)

mplayer (from mplayer-gui) doesn't honor "ao=pulse" from ~/.mplayer/config and popup scores of alsa error dialogs

Reported by: pacho@… Owned by: reimar
Priority: if idle Component: GUI
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

From: http://qa.mandriva.com/show_bug.cgi?id=37142

gmplayer (from mplayer-gui) doesn't honor "ao=pulse" from ~/.mplayer/config and
popup
scores of alsa error dialogs.
So there's two bugs:

  • it should report that error only once
  • it should read ~/.mplayer/config like CLI mplayer does

Thanks a lot

Change History (5)

comment:1 Changed 11 years ago by reimar

  • Priority changed from normal to if idle
  • Severity changed from normal to minor

These are two different bugs an should have been reported separately.

  • it should read ~/.mplayer/config like CLI mplayer does

It does, but the gui-specific config file of course has (and must have) priority.
You can set ao_driver in gui.conf any way you want.
Of course the intended way is to just set it via the Gui preferences.

  • it should report that error only once

¨that¨ is rather useless, what is the exact error message? What is the full output of gmplayer?

Either way take note that there is no further development on the Gui, occasionally I will do bug fixes, but do not expect much.
You really might want to consider switching to some actively developed frontend, e.g. smplayer.

comment:2 Changed 11 years ago by pacho@…

I will ask downstream

Thanks a lot

comment:3 Changed 11 years ago by thierry.vignaud@…

Without any ~/.mplayer/gui.conf, it displays:

[AO-ALSA] unable to find simple control 'PCM",0

This error dialogs pop up tons of dialogs every second, causing heavy window flickering.

comment:4 Changed 11 years ago by pacho@…

Where can system wide configurations for gui be set? (/etc/mplayer...?)

Thanks

comment:5 Changed 10 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

the dialog boxes are a duplicate bug
and the ao=pulse is your distro problem

* This bug has been marked as a duplicate of bug 743 *

Note: See TracTickets for help on using tickets.