Opened 11 years ago

Closed 11 years ago

#1092 closed defect (duplicate)

comma in -sub file name

Reported by: cben@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

If a subtitles file name given after "-sub" contains one or more comma characters (e.g. "FooBar?[1080p,BluRay?,x264].srt"), mplayer splits the name on the commas, trying to load each part (e.g. "FooBar?[1080p", "BluRay?", and "x264].srt") as a separate subtitles file. This of course fails.

This is a feature, it's even documented. But it's more harmful than useful!
If one wants to provide several sub files, one can always supply several "-sub" options. But there is currently no way to open a single file whose name contains a comma! So please remove this feature and treat the argument after "-sub" as a single literal file name.

The current work-around is renaming the file so that it contains no commas.
This is very annoying because commas in movie file names are frequent in the wild, and it's convenient for subtitle file names to match the movie file name, so this requires renaming a lot of files.

Change History (1)

comment:1 Changed 11 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

search for comma returns bug 309

* This bug has been marked as a duplicate of bug 309 *

Note: See TracTickets for help on using tickets.