Opened 11 years ago

Closed 9 years ago

#1095 closed defect (worksforme)

No video while playing HD movie from TS container

Reported by: dnd-only-my@… Owned by: reimar
Priority: normal Component: demuxer
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

openSUSE 10.3 x86

Tested on current SVN version:
MPlayer dev-SVN-r26924-4.2.1 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

And on last RC2 from Packman repository:
MPlayer 1.0rc2-SUSE Linux 10.3 (i686)-Packman-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Description:
I have an HD movie stored in TS container. Movie contains additionally two audio streams under numbers 4352 and 4353. When playing with no attributes - no errors. By when specifying audio stream with -aid option - no video appears, only selected audio stream played and error "Video: Cannot read properties." occurred (see below).
The only way to watch movie was to run two instances of mplayer - one with no parameters and muted sound, and one with -aid option.

Here an output:

NORMAL:

mplayer /mnt/tera1/video/Stargate.ts
MPlayer 1.0rc2-SUSE Linux 10.3 (i686)-Packman-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/tera1/video/Stargate.ts.
Cache fill: 15.72% (1318912 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4353) NO SUBS (yet)! PROGRAM N. 1
FPS seems to be: 23.976025
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 816 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [xv] 1920x816 => 1920x816 Planar YV12
A: 5.1 V: 5.1 A-V: 0.001 ct: -0.042 99/ 99 32% 3% 1.7% 0 0 85%

BROKEN WITH NO VIDEO:

mplayer -aid 4352 /mnt/tera1/video/Stargate.ts
MPlayer 1.0rc2-SUSE Linux 10.3 (i686)-Packman-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/tera1/video/Stargate.ts.
Cache fill: 16.31% (1368064 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)! PROGRAM N. 1

Too many audio packets in the buffer: (4096 in 7340032 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Video: Cannot read properties.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 6 ch, s16le, 448.0 kbit/9.72% (ratio: 56000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 5.8 (05.8) of 234680.8 (65:11:20.8) 1.2% 11%

Change History (10)

comment:1 Changed 11 years ago by dnd-only-my@…

I can share that movie for testing (or only part of it, because it is big - 12.2 GB).

comment:2 Changed 11 years ago by reimar

Tried switching between the audio streams at runtime with "#"?

comment:3 Changed 11 years ago by dnd-only-my@…

Sorry, I have tried to read documentation how to switch audio in realtime, but can't find clue.
I have tried to launch movie with gmplayer and then switch audio track from menu: Audio track -> Track 4352. Is it the same? After that video disappeared, but audio track correctly switcher to the russian. I can't switch back to default stream because no such option under Audio track submenu.
Also I have tried to play movie with VLC - yes, it glitches with video playback (perhaps codec problems) but at least it can correctly play selected audio streams and video together.

Here an output from gmplayer with switching audio track from menu on fly (first switch - to 4352, second - to 4353):

gmplayer /mnt/tera1/video/Звёздные\ врата.ts
MPlayer 1.0rc2-SUSE Linux 10.3 (i686)-Packman-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 7.52% (630784 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4353) NO SUBS (yet)! PROGRAM N. 1
FPS seems to be: 23.976025
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 816 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [xv] 1920x816 => 1920x816 Planar YV12
A: 6.4 V: 6.4 A-V: 0.002 ct: -0.040 129/129 33% 8% 2.1% 0 0 75%

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 15.53% (1302528 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)! PROGRAM N. 1

Too many audio packets in the buffer: (4096 in 7340032 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Video: Cannot read properties.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AUDIO: 48000 Hz, 6 ch, s16le, 448.0 kbit/9.72% (ratio: 56000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 6.4 (06.4) of 234680.8 (65:11:20.8) 1.2% 8%

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 6.15% (516096 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4353) NO SUBS (yet)! PROGRAM N. 1

Too many audio packets in the buffer: (3277 in 8389120 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Video: Cannot read properties.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 6.4 (06.4) of 164276.6 (45:37:56.5) 1.2% 19%
Exiting... (Exit)

P.S. I can give a torrent file with this movie and you can download it on very high speed to test.

comment:4 Changed 11 years ago by dnd-only-my@…

Sorry, I have tried to read documentation how to switch audio in realtime, but can't find clue.
I have tried to launch movie with gmplayer and then switch audio track from menu: Audio track -> Track 4352. Is it the same? After that video disappeared, but audio track correctly switcher to the russian. I can't switch back to default stream because no such option under Audio track submenu.
Also I have tried to play movie with VLC - yes, it glitches with video playback (perhaps codec problems) but at least it can correctly play selected audio streams and video together.

Here an output from gmplayer with switching audio track from menu on fly (first switch - to 4352, second - to 4353):

gmplayer /mnt/tera1/video/Звёздные\ врата.ts
MPlayer 1.0rc2-SUSE Linux 10.3 (i686)-Packman-4.2.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Quad CPU @ 2.40GHz (Family: 6, Model: 15, Stepping: 7)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 7.52% (630784 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4353) NO SUBS (yet)! PROGRAM N. 1
FPS seems to be: 23.976025
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 816 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [xv] 1920x816 => 1920x816 Planar YV12
A: 6.4 V: 6.4 A-V: 0.002 ct: -0.040 129/129 33% 8% 2.1% 0 0 75%

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 15.53% (1302528 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)! PROGRAM N. 1

Too many audio packets in the buffer: (4096 in 7340032 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Video: Cannot read properties.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AUDIO: 48000 Hz, 6 ch, s16le, 448.0 kbit/9.72% (ratio: 56000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 6.4 (06.4) of 234680.8 (65:11:20.8) 1.2% 8%

Playing /mnt/tera1/video/Звёздные врата.ts.
Cache fill: 6.15% (516096 bytes)
TS file format detected.
VIDEO H264(pid=4113) AUDIO A52(pid=4353) NO SUBS (yet)! PROGRAM N. 1

Too many audio packets in the buffer: (3277 in 8389120 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Video: Cannot read properties.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AUDIO: 48000 Hz, 6 ch, s16le, 640.0 kbit/13.89% (ratio: 80000->576000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 6.4 (06.4) of 164276.6 (45:37:56.5) 1.2% 19%
Exiting... (Exit)

P.S. I can give a torrent file with this movie and you can download it on very high speed to test.

comment:5 Changed 11 years ago by dnd-only-my@…

Sorry for double posting.

comment:6 Changed 11 years ago by compn

we just need 5 mb of it
dd if=input.ts of=smallclip.ts count=5 bs=1024k

and upload it to ftp://upload.mplayerhq.hu/MPlayer/incoming
as long as the 5mb sample still has the same problems
thanks!

comment:7 Changed 11 years ago by dnd-only-my@…

Hi again!
Yes, 5MB file still has same behavior. You can find it here:
ftp://upload.mplayerhq.hu/MPlayer/incoming/bug1095_stargate.ts
Upload has finished, but I can't list files in incoming directory, guess because of ftp setting. Please tell if upload was correct.

comment:8 Changed 10 years ago by compn

switching the audio track on the fly works for me , using # key (shift + 3 at the same time)

specifying -aid causes video to dissapear for some reason.

comment:9 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:10 Changed 9 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to work fine with latest SVN, though when using -demuxer lavf it complains a lot about incorrect timestamps, but it works with both demuxers.

Note: See TracTickets for help on using tickets.