Opened 12 years ago

Closed 12 years ago

#1119 closed defect (invalid)

uninitialised

Reported by: nicholenae@… Owned by: reimar
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc: catchconv-bugreports@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

This bug for the some people is not important but anyway i am reporting it.

Use of uninitialised value of size 4
==29328== Stack hash: 306191668
==29328== at 0x40A8A37: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==29328==
==29328== Conditional jump or move depends on uninitialised value(s)
==29328== Stack hash: 3485767050
==29328== at 0x40A8A65: (within /lib/tls/i686/cmov/libc-2.3.6.so)

Change History (4)

comment:1 Changed 12 years ago by nicholenae@…

This bug for the some people is not important but anyway i am reporting it.


Reproduce as follows:
http://www.cs.berkeley.edu/~nalvarez/20-mus2.mp3

valgrind mplayer 20-mus2.mp3

==813== Memcheck, a memory error detector.
==813== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==813== Using LibVEX rev 1854, a library for dynamic binary translation.
==813== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks? LLP.
==813== Using valgrind-3.3.1, a dynamic binary instrumentation framework.
==813== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==813== For more details, rerun with: -v
==813==
==813== My PID = 813, parent PID = 11401. Prog and args are:
==813== mplayer
==813== 20-mus2.mp3
==813==
==813== Use of uninitialised value of size 4
==813== Stack hash: 306191668
==813== at 0x40A8A37: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3485767050
==813== at 0x40A8A65: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3174169343
==813== at 0x40A8A6E: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2550973929
==813== at 0x40A8A80: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3567166085
==813== at 0x40A8A8C: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2090576585
==813== at 0x40A8AE0: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2614572241
==813== at 0x40A8B08: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Use of uninitialised value of size 4
==813== Stack hash: 3414564158
==813== at 0x40A8BE9: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Syscall param write(buf) points to uninitialised byte(s)
==813== Stack hash: 2550802113
==813== at 0x4000792: (within /lib/ld-2.3.6.so)
==813== Address 0x4416b86 is 34,478 bytes inside a block of size 65,664 alloc'd
==813== Stack hash: 2682576845
==813== at 0x401D96E: realloc (vg_replace_malloc.c:429)
==813== by 0x80DAA5E: decode_audio (dec_audio.c:401)
==813== by 0x80782F9: main (mplayer.c:2044)
==813==
==813== ERROR SUMMARY: 14 errors from 9 contexts (suppressed: 19 from 1)
==813== malloc/free: in use at exit: 52,428 bytes in 29 blocks.
==813== malloc/free: 19,258 allocs, 19,229 frees, 12,893,396 bytes allocated.
==813== For counts of detected errors, rerun with: -v
==813== searching for pointers to 29 not-freed blocks.
==813== checked 2,763,012 bytes.
==813==
==813== LEAK SUMMARY:
==813== definitely lost: 0 bytes in 0 blocks.
==813== possibly lost: 0 bytes in 0 blocks.
==813== still reachable: 52,428 bytes in 29 blocks.
==813== suppressed: 0 bytes in 0 blocks.
==813== Rerun with --leak-check=full to see details of leaked memory.


Memcheck, a memory error detector.
==813== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==813== Using LibVEX rev 1854, a library for dynamic binary translation.
==813== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks? LLP.
==813== Using valgrind-3.3.1, a dynamic binary instrumentation framework.
==813== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==813== For more details, rerun with: -v
==813==
==813== My PID = 813, parent PID = 11401. Prog and args are:
==813== mplayer
==813== 20-mus2.mp3
==813==
==813== Use of uninitialised value of size 4
==813== Stack hash: 306191668
==813== at 0x40A8A37: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3485767050
==813== at 0x40A8A65: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3174169343
==813== at 0x40A8A6E: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2550973929
==813== at 0x40A8A80: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 3567166085
==813== at 0x40A8A8C: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2090576585
==813== at 0x40A8AE0: (within /lib/tls/i686/cmov/libc-2.3.6.so)
==813==
==813== Conditional jump or move depends on uninitialised value(s)
==813== Stack hash: 2614572241
==813== at 0x40A8B08: (within /lib/tls/i686/cmov/libc-2.3.6.so)
:

comment:2 Changed 12 years ago by reimar

* Bug 1128 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by reimar

* Bug 1127 has been marked as a duplicate of this bug. *

comment:4 Changed 12 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Fixed in FFmpeg, INVALID here since it is not an MPlayer bug.

Note: See TracTickets for help on using tickets.