Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1122 closed defect (duplicate)

InvalidRead

Reported by: nicholenae@… Owned by: reimar
Priority: important Component: ao
Version: HEAD Severity: normal
Keywords: Cc: catchconv-bugreports@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I was working in the lab and find error in this file.

http://www.metafuzz.com/testcases/215334-50-1253153563-InvalidRead.tgz
tar xzfv 215334-50-1253153563-InvalidRead?.tgz
valgrind mplayer 50-mus8.wav

AO: [oss] 11025Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
==1705== Invalid read of size 2
==1705== Stack hash: 1119642782
==1705== at 0x80D99C9: decode_audio (ad_imaadpcm.c:2 58)
==1705== by 0x80DA974: decode_audio (dec_audio.c:383 )
==1705== by 0x80782F9: main (mplayer.c:2044)
==1705== Address 0x42fac80 is 0 bytes inside a block o f size 1 alloc'd
==1705== Stack hash: 2165705583
==1705== at 0x401C882: memalign (vg_replace_malloc.c :460)
==1705== by 0x80DAF5C: init_audio (dec_audio.c:77)
==1705== by 0x80DB408: init_best_audio_codec (dec_au dio.c:270)
==1705== by 0x8076588: reinit_audio_chain (mplayer.c :1585)
==1705== by 0x8077F31: main (mplayer.c:3583)
==1705==
==1705== Invalid read of size 1
==1705== Stack hash: 1119682483
==1705== at 0x80D99E6: decode_audio (ad_imaadpcm.c:2 60)
==1705== by 0x80DA974: decode_audio (dec_audio.c:383 )
==1705== by 0x80782F9: main (mplayer.c:2044)
==1705== Address 0x42fac82 is 1 bytes after a block of size 1 alloc'd
==1705== Stack hash: 2165705583
==1705== at 0x401C882: memalign (vg_replace_malloc.c :460)
==1705== by 0x80DAF5C: init_audio (dec_audio.c:77)
==1705== by 0x80DB408: init_best_audio_codec (dec_au dio.c:270)
==1705== by 0x8076588: reinit_audio_chain (mplayer.c :1585)
==1705== by 0x8077F31: main (mplayer.c:3583)
A: inf (-24.-8) of 0.0 (unknown) ??,?%

Exiting... (End of file)
==1705==
==1705== ERROR SUMMARY: 44316 errors from 2 contexts (s uppressed: 19 from 1)
==1705== malloc/free: in use at exit: 32,908 bytes in 1 2 blocks.
==1705== malloc/free: 24,496 allocs, 24,484 frees, 2,60 5,067 bytes allocated.
==1705== For counts of detected errors, rerun with: -v
==1705== searching for pointers to 12 not-freed blocks.
==1705== checked 2,747,144 bytes.
==1705==
==1705== LEAK SUMMARY:
==1705== definitely lost: 0 bytes in 0 blocks.
==1705== possibly lost: 0 bytes in 0 blocks.
==1705== still reachable: 32,908 bytes in 12 blocks.
==1705== suppressed: 0 bytes in 0 blocks.
==1705== Rerun with --leak-check=full to see details of leaked memory.
user@debian:~$ valgrind --log-file=log 50-mus8.wav mplayer 50-mus8.wav
valgrind: 50-mus8.wav: command not found
user@debian:~$ valgrind --log-file=log 50-mus8.wav valgrind: 50-mus8.wav: command not found
user@debian:~$ valgrind --log-file=log50 mplayer 50-mus8.wav MPlayer dev-SVN-r27139-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing 50-mus8.wav.
Audio file file format detected.


AO: [oss] 11025Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
==2212== Invalid read of size 2
==2212== Stack hash: 1119642782
==2212== at 0x80D99C9: decode_audio (ad_imaadpcm.c:258)
==2212== by 0x80DA974: decode_audio (dec_audio.c:383)
==2212== by 0x80782F9: main (mplayer.c:2044)
==2212== Address 0x42fac80 is 0 bytes inside a block of size 1 alloc'd
==2212== Stack hash: 2165705583
==2212== at 0x401C882: memalign (vg_replace_malloc.c:460)
==2212== by 0x80DAF5C: init_audio (dec_audio.c:77)
==2212== by 0x80DB408: init_best_audio_codec (dec_audio.c:270)==2212== by 0x8076588: reinit_audio_chain (mplayer.c:1585)
==2212== by 0x8077F31: main (mplayer.c:3583)
==2212==
==2212== Invalid read of size 1
==2212== Stack hash: 1119682483
==2212== at 0x80D99E6: decode_audio (ad_imaadpcm.c:260)
==2212== by 0x80DA974: decode_audio (dec_audio.c:383)
==2212== by 0x80782F9: main (mplayer.c:2044)
==2212== Address 0x42fac82 is 1 bytes after a block of size 1 alloc'd
==2212== Stack hash: 2165705583
==2212== at 0x401C882: memalign (vg_replace_malloc.c:460)
==2212== by 0x80DAF5C: init_audio (dec_audio.c:77)
==2212== by 0x80DB408: init_best_audio_codec (dec_audio.c:270)==2212== by 0x8076588: reinit_audio_chain (mplayer.c:1585)
==2212== by 0x8077F31: main (mplayer.c:3583)
A: inf (-24.-8) of 0.0 (unknown) ??,?%

Change History (3)

comment:1 Changed 11 years ago by nicholenae@…

  • bug_file_loc set to http://www.cs.berkeley.edu/~nalvarez/50-mus8.wav

comment:2 Changed 11 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

This was already fixed since several days when you reported it, and a duplicate in addition...

* This bug has been marked as a duplicate of bug 1114 *

comment:3 Changed 11 years ago by nicholenae@…

  • Cc catchconv-bugreports@… added

(In reply to comment #0)

I was working in the lab and find error in this file.

I have This version:

MPlayer dev-SVN-r27139-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz (Family: 6, Model: 15,
Stepping: 13)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE

http://www.metafuzz.com/testcases/215334-50-1253153563-InvalidRead.tgz
tar xzfv 215334-50-1253153563-InvalidRead?.tgz
valgrind mplayer 50-mus8.wav

AO: [oss] 11025Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
==1705== Invalid read of size 2
==1705== Stack hash: 1119642782
==1705== at 0x80D99C9: decode_audio (ad_imaadpcm.c:2 58)
==1705== by 0x80DA974: decode_audio (dec_audio.c:383 )
==1705== by 0x80782F9: main (mplayer.c:2044)
==1705== Address 0x42fac80 is 0 bytes inside a block o f size 1 alloc'd
==1705== Stack hash: 2165705583
==1705== at 0x401C882: memalign (vg_replace_malloc.c :460)
==1705== by 0x80DAF5C: init_audio (dec_audio.c:77)
==1705== by 0x80DB408: init_best_audio_codec (dec_au dio.c:270)
==1705== by 0x8076588: reinit_audio_chain (mplayer.c :1585)
==1705== by 0x8077F31: main (mplayer.c:3583)
==1705==
==1705== Invalid read of size 1
==1705== Stack hash: 1119682483
==1705== at 0x80D99E6: decode_audio (ad_imaadpcm.c:2 60)
==1705== by 0x80DA974: decode_audio (dec_audio.c:383 )
==1705== by 0x80782F9: main (mplayer.c:2044)
==1705== Address 0x42fac82 is 1 bytes after a block of size 1 alloc'd
==1705== Stack hash: 2165705583
==1705== at 0x401C882: memalign (vg_replace_malloc.c :460)
==1705== by 0x80DAF5C: init_audio (dec_audio.c:77)
==1705== by 0x80DB408: init_best_audio_codec (dec_au dio.c:270)
==1705== by 0x8076588: reinit_audio_chain (mplayer.c :1585)
==1705== by 0x8077F31: main (mplayer.c:3583)
A: inf (-24.-8) of 0.0 (unknown) ??,?%

Exiting... (End of file)
==1705==
==1705== ERROR SUMMARY: 44316 errors from 2 contexts (s uppressed: 19 from 1)
==1705== malloc/free: in use at exit: 32,908 bytes in 1 2 blocks.
==1705== malloc/free: 24,496 allocs, 24,484 frees, 2,60 5,067 bytes allocated.
==1705== For counts of detected errors, rerun with: -v
==1705== searching for pointers to 12 not-freed blocks.
==1705== checked 2,747,144 bytes.
==1705==
==1705== LEAK SUMMARY:
==1705== definitely lost: 0 bytes in 0 blocks.
==1705== possibly lost: 0 bytes in 0 blocks.
==1705== still reachable: 32,908 bytes in 12 blocks.
==1705== suppressed: 0 bytes in 0 blocks.
==1705== Rerun with --leak-check=full to see details of leaked memory.
user@debian:~$ valgrind --log-file=log 50-mus8.wav mplayer 50-mus8.wav
valgrind: 50-mus8.wav: command not found
user@debian:~$ valgrind --log-file=log 50-mus8.wav valgrind: 50-mus8.wav:
command not found
user@debian:~$ valgrind --log-file=log50 mplayer 50-mus8.wav MPlayer
dev-SVN-r27139-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz (Family: 6, Model: 15,
Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing 50-mus8.wav.
Audio file file format detected.


AO: [oss] 11025Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
==2212== Invalid read of size 2
==2212== Stack hash: 1119642782
==2212== at 0x80D99C9: decode_audio (ad_imaadpcm.c:258)
==2212== by 0x80DA974: decode_audio (dec_audio.c:383)
==2212== by 0x80782F9: main (mplayer.c:2044)
==2212== Address 0x42fac80 is 0 bytes inside a block of size 1 alloc'd
==2212== Stack hash: 2165705583
==2212== at 0x401C882: memalign (vg_replace_malloc.c:460)
==2212== by 0x80DAF5C: init_audio (dec_audio.c:77)
==2212== by 0x80DB408: init_best_audio_codec (dec_audio.c:270)==2212== by
0x8076588: reinit_audio_chain (mplayer.c:1585)
==2212== by 0x8077F31: main (mplayer.c:3583)
==2212==
==2212== Invalid read of size 1
==2212== Stack hash: 1119682483
==2212== at 0x80D99E6: decode_audio (ad_imaadpcm.c:260)
==2212== by 0x80DA974: decode_audio (dec_audio.c:383)
==2212== by 0x80782F9: main (mplayer.c:2044)
==2212== Address 0x42fac82 is 1 bytes after a block of size 1 alloc'd
==2212== Stack hash: 2165705583
==2212== at 0x401C882: memalign (vg_replace_malloc.c:460)
==2212== by 0x80DAF5C: init_audio (dec_audio.c:77)
==2212== by 0x80DB408: init_best_audio_codec (dec_audio.c:270)==2212== by
0x8076588: reinit_audio_chain (mplayer.c:1585)
==2212== by 0x8077F31: main (mplayer.c:3583)
A: inf (-24.-8) of 0.0 (unknown) ??,?%

Note: See TracTickets for help on using tickets.