Opened 11 years ago

Closed 11 years ago

#1124 closed defect (duplicate)

InvalidRead

Reported by: nicholenae@… Owned by: reimar
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc: nicholenae@…, catchconv-bugreports@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

http://www.metafuzz.com/testcases/857469-313-2290411349-UninitValue.tgz
tar xzfv 857469-96-3747044012-InvalidRead?.tgz
valgrind mplayer 96-mus2.mp3

==3638== Memcheck, a memory error detector.
==3638== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==3638== Using LibVEX rev 1854, a library for dynamic binary translation.
==3638== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks? LLP.
==3638== Using valgrind-3.3.1, a dynamic binary instrumentation
framework.
==3638== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==3638== For more details, rerun with: -v
==3638==
==3638== My PID = 3638, parent PID = 27019. Prog and args are:
==3638== mplayer
==3638== 96-mus2.mp3
==3638==
==3638== Invalid read of size 4

==3638== Stack hash: 2607104291
==3638== at 0x846E817: mp_decode_layer3 (bitstream.h:658)
==3638== by 0x846F709: mp_decode_frame (mpegaudiodec.c:2305)
==3638== by 0x84715AD: decode_frame (mpegaudiodec.c:2401)
==3638== by 0x82ECD1A: avcodec_decode_audio2 (utils.c:927)
==3638== by 0x8263CC9: av_find_stream_info (utils.c:1776)
==3638== by 0x81A314E: demux_open_lavf (demux_lavf.c:466)
==3638== by 0x811E2DE: demux_open_stream (demuxer.c:864)
==3638== by 0x811E5B1: demux_open (demuxer.c:991)
==3638== by 0x80777AE: main (mplayer.c:3238)
==3638== Address 0x433578c is 4 bytes after a block of size 872

Change History (3)

comment:1 Changed 11 years ago by nicholenae@…

  • Cc catchconv-bugreports@… added

I has working in the lab and found bugs (4 invalid Read) in one file (96-mus2.mp3). I used

this commands for find bugs.

http://www.metafuzz.com/testcases/857469-313-2290411349-UninitValue.tgz

tar xzfv 857469-96-3747044012-InvalidRead?.tgz
valgrind mplayer 96-mus2.mp3


MPlayer dev-SVN-r27139-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz (Family: 6, Model: 15, Stepping: 13)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

==3638== Memcheck, a memory error detector.
==3638== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==3638== Using LibVEX rev 1854, a library for dynamic binary translation.
==3638== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks? LLP.
==3638== Using valgrind-3.3.1, a dynamic binary instrumentation
framework.
==3638== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==3638== For more details, rerun with: -v
==3638==
==3638== My PID = 3638, parent PID = 27019. Prog and args are:
==3638== mplayer
==3638== 96-mus2.mp3
==3638==
==3638== Invalid read of size 4

==3638== Stack hash: 2607104291
==3638== at 0x846E817: mp_decode_layer3 (bitstream.h:658)
==3638== by 0x846F709: mp_decode_frame (mpegaudiodec.c:2305)
==3638== by 0x84715AD: decode_frame (mpegaudiodec.c:2401)
==3638== by 0x82ECD1A: avcodec_decode_audio2 (utils.c:927)
==3638== by 0x8263CC9: av_find_stream_info (utils.c:1776)
==3638== by 0x81A314E: demux_open_lavf (demux_lavf.c:466)
==3638== by 0x811E2DE: demux_open_stream (demuxer.c:864)
==3638== by 0x811E5B1: demux_open (demuxer.c:991)
==3638== by 0x80777AE: main (mplayer.c:3238)
==3638== Address 0x433578c is 4 bytes after a block of size 872

comment:2 Changed 11 years ago by nicholenae@…

  • Cc nicholenae@… added

I has working in the lab and found bugs (4 invalid Read) in one file (96-mus2.mp3). I used this commands for find bugs.

http://www.metafuzz.com/testcases/857469-96-3747044012-InvalidRead.tgz

tar xzfv 857469-96-3747044012-InvalidRead?.tgz
valgrind mplayer 96-mus2.mp3


MPlayer dev-SVN-r27139-4.1.2 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz (Family: 6, Model: 15,
Stepping: 13)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

==3638== Memcheck, a memory error detector.
==3638== Copyright (C) 2002-2007, and GNU GPL'd, by Julian Seward et al.
==3638== Using LibVEX rev 1854, a library for dynamic binary translation.
==3638== Copyright (C) 2004-2007, and GNU GPL'd, by OpenWorks? LLP.
==3638== Using valgrind-3.3.1, a dynamic binary instrumentation
framework.
==3638== Copyright (C) 2000-2007, and GNU GPL'd, by Julian Seward et al.
==3638== For more details, rerun with: -v
==3638==
==3638== My PID = 3638, parent PID = 27019. Prog and args are:
==3638== mplayer
==3638== 96-mus2.mp3
==3638==
==3638== Invalid read of size 4

==3638== Stack hash: 2607104291
==3638== at 0x846E817: mp_decode_layer3 (bitstream.h:658)
==3638== by 0x846F709: mp_decode_frame (mpegaudiodec.c:2305)
==3638== by 0x84715AD: decode_frame (mpegaudiodec.c:2401)
==3638== by 0x82ECD1A: avcodec_decode_audio2 (utils.c:927)
==3638== by 0x8263CC9: av_find_stream_info (utils.c:1776)
==3638== by 0x81A314E: demux_open_lavf (demux_lavf.c:466)
==3638== by 0x811E2DE: demux_open_stream (demuxer.c:864)
==3638== by 0x811E5B1: demux_open (demuxer.c:991)
==3638== by 0x80777AE: main (mplayer.c:3238)
==3638== Address 0x433578c is 4 bytes after a block of size 872

comment:3 Changed 11 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of bug 1123 *

Note: See TracTickets for help on using tickets.