Opened 11 years ago

Closed 11 years ago

#1286 closed defect (invalid)

AVI movie (DogHeart-CD1.avi) causes BadShmSeg

Reported by: yuri@… Owned by: reimar
Priority: important Component: core
Version: 1.0rc2 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I am playing an attached movie I get the errors, see below.

Yuri

MPlayer 1.0rc2-4.2.1 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 4, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing dog-heart-1-1M.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [DIVX] 720x576 24bpp 25.000 fps 1434.8 kbps (175.1 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 112.0 kbit/7.94% (ratio: 14000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x8851830]looks like this file was encoded with (divx4/(old)xvid/opendivx) -> forcing low_delay flag
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 720x576 => 720x576 Planar YV12
X11 error: BadAccess? (attempt to access private resource denied)
X11 error: BadAccess? (attempt to access private resource denied)
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 0 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0
X11 error: BadShmSeg? (invalid shared segment parameter)% ??,?% 1 0

Attachments (1)

dog-heart-1-1M.avi (263.8 KB) - added by yuri@… 11 years ago.
Movie causing a problem

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by yuri@…

Movie causing a problem

comment:1 Changed 11 years ago by yuri@…

comment:2 Changed 11 years ago by yuri@…

  • Resolution set to invalid
  • Status changed from new to closed

Problem disappeared after the system update.

Possibly incomplete update is to blame.

Yuri

Note: See TracTickets for help on using tickets.