Opened 11 years ago

Last modified 9 years ago

#1380 closed defect (worksforme)

m4a files with embedded art fail to play

Reported by: fejcxh802@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: compn, hhielscher@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When playing any of the podcasts from the below link, SMPlayer loads the
first embedded artwork, plays about a second of the file, then stops.

I have reported this to the SMPlayer developers but they have advised that it's an MPlayer issue, hence the report here. Hopefully you can resolve - I'm not familiar with the MPlayer project and components, but have been actively reporting bugs in the SMPlayer project and have a bit of Linux experience. Hopefully this report gives enough info to go on :)

I have guessed the component as it means nothing to me - sorry!

Looking at the MPlayer logs, this could be the cause:

Too many audio packets in the buffer: (4096 in 1120064 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Exiting... (End of file)
ID_EXIT=EOF

The podcasts can be downloaded from here for testing:

http://www.zen54064.zen.co.uk/Hospital%20Records%20Podcast%201.xml

VLC Player can handle these files without a problem and plays them fully.

SMPlayer 0.6.6 (SVN r2599)
MPlayer SVN r28238
Ubuntu Intrepid x86

Change History (6)

comment:1 Changed 11 years ago by compn

try -mc 0

comment:2 Changed 11 years ago by compn

i can play it using mplayer hp77.m4a -vc dummy
or mplayer -novideo hp77.m4a
or mplayer -vc null -vo null hp77.m4a

seems to be a bug somewhere...

comment:3 Changed 11 years ago by fejcxh802@…

Glad you could confirm this bug - hopefully it can be resolved :)

comment:4 Changed 10 years ago by hhielscher@…

  • Cc hhielscher@… added

comment:5 Changed 10 years ago by fejcxh802@…

Bug still present in the current version of Mplayer.

Example m4a files can be found at the new RSS feed here:

http://podcast.hospitalrecords.com/HospitalRecordsPodcast.xml

comment:6 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

works for me since lavf was made default for mp4/mov/m4a files

Note: See TracTickets for help on using tickets.