Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#141 closed defect (fixed)

Rebuild option --without esd doesnt work

Reported by: kristof.p@… Owned by: dominik@…
Priority: normal Component: RPMs
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

On machine, where no esd-devel package is installed I did:

rpmbuild -ba mplayer.spec --without esd

and did got error:
Failed build dependencies:
esd-devel is needed by mplayer

This is because there is forget hardcoded tag in spec file:
BuildRequires?: esd-devel
on line 129 around

Change History (5)

comment:1 Changed 14 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

This is not an MPlayer bug, it's a bug in the RPM package. Report to whoever
created the RPM.

comment:2 Changed 14 years ago by reimar

Hmm... I overlooked that we actually have a component RPMs here... You should
still mention where you go the rpm from and what version it is etc...

comment:3 Changed 14 years ago by kristof.p@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Package version:
mplayer-1.0pre5

from mplayerhq.hu-> Download (source and binaries) -> Red Hat / Fedora RPM
packages (US repository)

This is hosted on http://luna.cs.ccsu.edu/dominik/mplayer/
and description says Report bugs in this package in mplayer's bugzila
component -RPMs

comment:4 Changed 14 years ago by reimar

Package version:
mplayer-1.0pre5

It probably applies to all, but there are packages for Fedora Core 1, 2, RedHat?
7-9. That's why I suggested that you give the download URL - that should answer
any questions in that regard ;-)...

This is hosted on http://luna.cs.ccsu.edu/dominik/mplayer/
and description says Report bugs in this package in mplayer's bugzila
component -RPMs

Yes, sorry, I wasn't completely up-to-date on what bugzilla is used for...

comment:5 Changed 14 years ago by kristof.p@…

  • Resolution set to fixed
  • Status changed from reopened to closed

Reimar,

thanks for pointing me to specify more precisely version.

I talked about source src rpm package mplayer-1.0pre5-2.src.rpm,
what is the one and the same for all Fedora/Redhat? distro versions.

This package contains file mplayer.spec
($Revision: 1.61 $, $Date: 2004/07/25 23:47:00 $

but the last update of mplayer.spec in CVS is
($Revision: 1.65 $, $Date: 2004/09/23 22:34:27 $)
and it is already fixed.

So using the unstable mplayer-1.0pre6-0.20040924.1.src.rpm
solves this problem.

Thank you for advice.

Marking as RESOLVED FIXED, because this issue is fixed
on unstable/cvs version.

Note: See TracTickets for help on using tickets.