Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1420 closed defect (invalid)

Problems with parsing certain embedded ass subtitles

Reported by: soltys@… Owned by: eugeni.stepanov@…
Priority: normal Component: libass
Version: HEAD Severity: normal
Keywords: Cc: soltys@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've uploaded fragment of offending file to recommended ftp site. File's name is ass-parse-problem.mkv, with the same description as here (+log) in a txt file.

Anyway - Whenever I play the file, I get (with -v 1) the following, when the first line of the subtitle is about to be displayed:

event at 17211, +-9223372036854775808: Dialogue: 0,0:00:17.21,0:00:19.31,Main,Kan'u,0000,0000,0000A dream, eh?

[ass] [0x3de2e58] Warning: no style named '0:00:19.31' found, using 'Main'
[postproc @ 0x1161c04]using npp filters 0x4404/0x4404

If I extract the ass file and load it separately - then everything works and is displayed properly. Not really sure what is the culprit here - subtitle file looks fine, unless single quote is not allowed for some reason.

Change History (9)

comment:1 Changed 10 years ago by soltys@…

  • Cc soltys@… added

comment:2 Changed 10 years ago by soltys@…

  • Cc soltys@… removed

comment:3 Changed 10 years ago by soltys@…

  • Cc soltys@… added

comment:4 Changed 10 years ago by eugeni.stepanov@…

Can't reproduce on linux x86. Are you using svn head?

comment:5 Changed 10 years ago by soltys@…

This one was was taken directly from http://kovensky.project357.com/ - so latest is for sure not HEAD - but considering dates pretty close, and uses experimental mt code on top of it. I'll try to reproduce under linux with true SVN head.

Btw, this is the (win32) config I used:

quiet=no

msgcolor=yes
vo=directx
ao=dsound

screenw=1680
screenh=1050
geometry=0:0

embeddedfonts=yes
fontconfig=yes
font=Arial

alang=unk,jpn,jp,eng,en
slang=unk,eng,en,jpn,jp

ass=yes
subfont-autoscale=3

ass-font-scale=1
ass-hinting=3
subfont-osd-scale=1.5
subfont-text-scale=2.5

channels=2

menu=no
sws=9
zoom=yes
autoq=100
vf=pp=ha:128:7/va/dr,scale=1680:-2,ass
xy=1672

lavdopts=er=1:threads=2

comment:6 Changed 10 years ago by eugeni.stepanov@…

event at 17211, +-9223372036854775808: Dialogue:

This points to a demuxer problem. Maybe mt code is to blame.

comment:7 Changed 10 years ago by greg@…

Kovensky's build uses the lavf demuxer by default, which causes this issue. I think he has put up a fixed build on his site already. If not, please use "-demuxer mkv" to get around this problem.

comment:8 Changed 10 years ago by greg@…

  • Resolution set to invalid
  • Status changed from new to closed

This wasn't a bug in MPlayer anyway.

comment:9 Changed 10 years ago by soltys@…

Thanks for info, everything works fine now.

Note: See TracTickets for help on using tickets.