Opened 10 years ago

Closed 9 years ago

#1431 closed defect (worksforme)

mpeg/mp2 audio is garbled in lavf demuxer, works with ffmpeg

Reported by: compn Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

http://samples.mplayerhq.hu/A-codecs/mp2-bug/mpeg-adts-mp2-48hz.mp2

F:\>mplaye mpeg-adts-mp2-48hz.mp2
MPlayer GIT-6e54f40-4.2.1-sjlj-Kovensky-mt 20090304 (C) 2000-2009 MPlayer Team
137 audio & 302 video codecs
c:\winnt\fonts\comic.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: c:\winnt\fonts\comic.ttf

Playing mpeg-adts-mp2-48hz.mp2.
libavformat file format detected.
[lavf] Audio stream found, -aid 0
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [dsound] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 0.9 (00.9) of 131.1 (02:11.0) 0.3%
Exiting... (Quit)

F:\>ffmpeg -i mpeg-adts-mp2-48hz.mp2
FFmpeg version SVN-r16043-Sherpya, Copyright (c) 2000-2008 Fabrice Bellard, et al.

libavutil 49.12. 0 / 49.12. 0
libavcodec 52. 6. 1 / 52. 6. 1
libavformat 52.23. 1 / 52.23. 1
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 1. 0 / 0. 1. 0
libswscale 0. 6. 1 / 0. 6. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Dec 10 2008 18:25:26, gcc: 4.2.5 20080919 (prerelease) [Sherpya]

Input #0, mpeg, from 'mpeg-adts-mp2-48hz.mp2':

Duration: 00:02:10.32, start: 56544.790478, bitrate: 321 kb/s

Stream #0.0[0x1c0]: Audio: mp2, 48000 Hz, stereo, s16, 320 kb/s

At least one output file must be specified

Change History (1)

comment:1 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

works for me in svn.

Note: See TracTickets for help on using tickets.