Opened 10 years ago

Closed 9 years ago

#1469 closed defect (fixed)

Problems with vp6a decoding

Reported by: yaroslav.isakov@… Owned by: reimar
Priority: unimportant Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hello! I have a problem with one of my .flv files. It have VP6A encoded video. When I try to play this file with MPlayer (Gentoo package 1.0_rc2_p20090322, it is same as svn revision 29040), it doesn't plays, and shows me many errors:
Unsupported PixelFormat? 35
Unsupported PixelFormat? 35
VDec: запрос vo config - 320 x 240 (предпочитаемое цветовое пространство: Unknown 0x0000)
Не могу найти подходящее цветовое пространство - попытаюсь с -vf scale...
Открываю видео фильтр: [scale]
Извините, выбранное устройство видеовывода не совместимо с этим кодеком.
Попробуйте добавить фильтр scale к вашему списку фильтров.
Например, -vf spp,scale вместо -vf spp.
But, with ffplay (ffmpeg-0.5-r1 Gentoo package) video plays very well!
This video may be downloaded from http://www.utmn.ru/video/lection2-2.flv (direct link)

Change History (2)

comment:1 Changed 10 years ago by compn

known problem
i think the vp6a codec/colorspace has to be mapped to a different colorspace in mplayer.

comment:2 Changed 9 years ago by compn

  • Priority changed from important to unimportant
  • Resolution set to fixed
  • Status changed from new to closed

this was fixed in svn and lection2-2.flv works for me now.

Note: See TracTickets for help on using tickets.