Opened 11 years ago

Closed 11 years ago

#1496 closed defect (fixed)

OpenSolaris 2009.06 doesn't grok -rdynamic

Reported by: nikke@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc: ptecza@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When trying to compile mplayer HEAD (actually, the snapshot tarball) on OpenSolaris? compilation/linking bombs out with syntax errors when the -rdynamic option is being used by the build system.

After googling around and browsing some forums it seems that the standard solution is to remove the -rdynamic stuff from configure on Solaris.

Noone seems to have cobbled up a reasonable patch for it though, so I'll include a rough one with this bug report.

Attachments (1)

mplayer-solconfig.patch (582 bytes) - added by nikke@… 11 years ago.
Patch to not use -rdynamic on SunOS (Solaris/OpenSolaris?).

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by nikke@…

Patch to not use -rdynamic on SunOS (Solaris/OpenSolaris?).

comment:1 Changed 11 years ago by nikke@…

comment:2 Changed 11 years ago by ptecza@…

  • Cc ptecza@… added

The issue with -rdynamic option occurs because gcc from OpenSolaris? 2009.06
doesn't recognize that option:

$ ./configure --prefix=/opt/mplayer
$ gmake
[...]
libmpcodecs/ve_vfw.c: In function `vfw_open_encoder':
libmpcodecs/ve_vfw.c:134: warning: int format, different type arg (arg 4)
cc -o mencoder mencoder.o mp_msg-mencoder.o parser-mecmd.o [...] libavutil/libavutil.a libpostproc/libpostproc.a libswscale/libswscale.a -ffast-math -lkstat -lposix4 -lsocket -lnsl -lsmbclient -lpng -lz -ljpeg -L/lib -lfreetype -lfontconfig -lz -lbz2 -lspeex -rdynamic -L/usr/lib -lm
cc: unrecognized option `-rdynamic'

Here is more details about OpenSolaris? gcc:

$ cc -v
Reading specs from /usr/sfw/lib/gcc/i386-pc-solaris2.11/3.4.3/specs
Configured with: /builds2/sfwnv-111a/usr/src/cmd/gcc/gcc-3.4.3/configure --prefix=/usr/sfw --with-as=/usr/sfw/bin/gas --with-gnu-as --with-ld=/usr/ccs/bin/ld --without-gnu-ld --enable-languages=c,c++,f77,objc --enable-shared
Thread model: posix
gcc version 3.4.3 (csl-sol210-3_4-20050802)

It seems that only libmpcodecs/vd_xanim.c file needs -rdynamic option of gcc
under OpenSolaris?, so I've workarounded that problem by disabling xanim :)
I hope it wasn't the most stupid thing in my life and I don't need xanim
on OpenSolaris? box. Please correct me, if I'm wrong.

$ ./configure --prefix=/opt/mplayer --disable-xanim

comment:3 Changed 11 years ago by diego@…

  • rep_platform changed from PC (AMD64) to All
  • Resolution set to fixed
  • Status changed from new to closed

Thanks, patch applied.

Note: See TracTickets for help on using tickets.