Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#150 closed defect (fixed)

ffmpeg4 always conceals 2^31 errors

Reported by: mplayerHQ@… Owned by: diego@…
Priority: normal Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

when encounter damaged file , some messages may be printed .
[mpeg4 @ 0x83d98c8]ac-tex damaged at 8 12
[mpeg4 @ 0x83d98c8]Error at MB: 500
[mpeg4 @ 0x83d98c8]concealing 2147483647 errors

the concealed error number is always fixed at 231 errors .

Change History (6)

comment:1 Changed 14 years ago by diego@…

Elaborate what you mean and please provide a sample file.

comment:2 Changed 14 years ago by jknutar@…

[mpeg4 @ 0x83d98c8]concealing 2147483647 errors

The number 2147483647 remains constant, regardless of file and how damaged the
file is. Besides the amount of errors being somewhat strangely high, one would
assume that it wouldn't be the exact same amount of errors for every damaged
frame, so the counter is showing bogus info.

comment:3 Changed 14 years ago by jknutar@…

  • Severity changed from normal to minor

comment:4 Changed 14 years ago by reimar

  • Severity changed from minor to normal

This is normal for certain errors, see e.g. libavcodec/error_resilience.c line 635.
It seems that it means something like "completely broken", or at least that it
is unclear how many errors there really are...
But I guess this info is useless for most people, so maybe this should be
reduced to AV_LOG_DEBUG level...

comment:5 Changed 14 years ago by castet.matthieu@…

Seem the bug is fixed.

Revision 1.27 / (download) - annotate - [select for diffs] , Fri Jan 21 23:47:03
2005 UTC (5 days, 16 hours ago) by michael
Branch: MAIN
CVS Tags: HEAD
Changes since 1.26: +12 -3 lines
Diff to previous 1.26

count errors instead of printing 231

http://www1.mplayerhq.hu/cgi-bin/cvsweb.cgi/ffmpeg/libavcodec/error_resilience.c.diff?r1=1.26&r2=1.27&cvsroot=FFMpeg&sortby=date

comment:6 Changed 14 years ago by diego@…

  • op_sys changed from FreeBSD to All
  • Resolution set to fixed
  • Status changed from new to closed

Yes, Michael recently fixed this.

Note: See TracTickets for help on using tickets.