Opened 10 years ago

Last modified 8 years ago

#1554 closed defect (fixed)

[dca @ 0xd536e0]Not a valid DCA frame

Reported by: fragabr@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When playing some m2ts ripped from blu-ray with DTS-HD, I get those messages:

[dca @ 0xd536e0]Not a valid DCA frame
[dca @ 0xd536e0]Not a valid DCA frame
[dca @ 0xd536e0]Not a valid DCA frame

it happens on all movies with DTS-HD only (True-HD is ok).

And I noticed that the DTS-HD audio is slightly out of sync with the video.

Change History (4)

comment:1 Changed 10 years ago by compn

we need a small sample ts file that has this problem
if you want us to look/fix it.

also try in ffmpeg.

comment:2 Changed 10 years ago by fragabr@…

I uploaded sample-dts-not-valid-dca-frame.m2ts (~100MB) to incoming .I hope it is enough. The DTS-HD track is the following:

Track ID: 4352
Stream type: DTS-HD
Stream ID: A_DTS
Stream info: Bitrate: 1536Kbps core + MLP data.Sample Rate: 48KHz Channels: 5.1 (DTS Master Audio)

If the sample is not enough, please tell me so I can use tsMuxer to remove the useless tracks and upload just the important tracks again. Thanks.

Ps: ffplay is too slow to play this. It takes a long time... MPlayer is much faster.

comment:3 Changed 10 years ago by fragabr@…

Observation: if I use -demuxer lavf this problem doesn't happen.

comment:4 Changed 8 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

works for me in svn.

Note: See TracTickets for help on using tickets.