Opened 9 years ago

Closed 9 years ago

#1618 closed defect (worksforme)

Does not recognize SMIL file from radioBERLIN 88.8.

Reported by: paulepanter@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Dear MPlayer hackers,

I tried to listen to the radio station radioBERLIN 88.8 which also offers a Real Audio stream. The M$ Windows media stream (live.wax) works fine.

I am using Debian Sid/unstable with the DMO (debian-multimedia.org) version of MPlayer 1:1.0.rc2svn20091220-0.0.

---
$ mplayer -ao pulse http://www.radioberlin.de/live.smil
MPlayer SVN-r30075 (C) 2000-2009 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing http://www.radioberlin.de/live.smil.
Resolving www.radioberlin.de for AF_INET6...
Couldn't resolve name for AF_INET6: www.radioberlin.de
Resolving www.radioberlin.de for AF_INET...
Connecting to server www.radioberlin.de[192.108.72.53]: 80...
Cache size set to 320 KBytes
Cache fill: 0.18% (574 bytes)

Exiting... (End of file)
---

Then I downloaded the file and turned on debugging.

---
$ mplayer -ao pulse -msglevel all=9 live.smil
Adding file live.smil
Config pushed level is now 2
Config pushed level is now 3
MPlayer SVN-r30075 (C) 2000-2009 MPlayer Team
CPU vendor name: AuthenticAMD max cpuid level: 1
CPU: AMD Athlon(tm) X2 Dual Core Processor BE-2350 (Family: 15, Model: 107, Stepping: 2)
extended cpuid-level: 24
extended cache-info: 33587520
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNowExt: 1 SSE: 1 SSE2: 1 SSSE3: 0
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/home/x/.mplayer/codecs.conf'
Reading /home/x/.mplayer/codecs.conf: Can't open '/home/x/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration: --prefix=/usr --confdir=/etc/mplayer --datadir=/usr/share/mplayer --enable-xmga --enable-mga --enable-joystick --disable-tremor-internal --enable-libopencore_amrnb --enable-libopencore_amrwb --disable-openal --disable-faad-internal --disable-liba52-internal --language=all --enable-largefiles --enable-menu --disable-libdvdcss-internal --enable-radio --enable-radio-capture --enable-xvmc --with-xvmclib=XvMCW --enable-win32dll --enable-tdfxfb --enable-s3fb --enable-zr --realcodecsdir=/usr/lib/codecs --xanimcodecsdir=/usr/lib/codecs --enable-gui --enable-runtime-cpudetection
CommandLine?: '-ao' 'pulse' '-msglevel' 'all=9' 'live.smil'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/home/x/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/x/.mplayer/input.conf'
Can't open input config file /home/x/.mplayer/input.conf: No such file or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 90 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
get_path('live.smil.conf') -> '/home/x/.mplayer/live.smil.conf'

[init getch2?]

Playing live.smil.
get_path('sub/') -> '/home/x/.mplayer/sub/'
[file] File size is 574 bytes
STREAM: [file] live.smil
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
s->pos=0 newpos=0 new_bufpos=0 buflen=0
LAVF_check: no clue about this gibberish!
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for YUV4MPEG2
DEMUXER: freeing demuxer at 0x9be1cc8
ASF_check: not ASF guid!
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for REAL
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for SMJPEG
DEMUXER: freeing demuxer at 0x9be1cc8
[mkv] no head found
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
Ogg demuxer : Bad page sync
DEMUXER: freeing demuxer at 0x9be1cc8
Searching demuxer type for filename live.smil ext: .smil
s->pos=0 newpos=0 new_bufpos=0 buflen=0
Checking for Nullsoft Streaming Video
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
Checking for MOV
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for VIVO
header block 1 size: 63
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
DEMUXER: freeing demuxer at 0x9be1cc8
AVS: avs_check_file - attempting to open file live.smil
AVS: failed to load avisynth.dll
AVS: Init failed
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for PVA
Failed: PVA
DEMUXER: freeing demuxer at 0x9be1cc8
Checking for MPEG-TS...
THIS DOESN'T LOOK LIKE AN MPEG-TS FILE!
TRIED UP TO POSITION 0, FOUND ffffff00, packet_size= 0, SEEMS A TS? 0
s->pos=23E newpos=0 new_bufpos=0 buflen=0
stream_seek: WARNING! Can't seek to 0x0 !
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
Checking for LMLM4 Stream Format
typ: 30829 chan: 15423 size: 1814066781 pad: 411
Invalid packet in LMLM4 stream: ch=15423 size=1814066781
LMLM4 Stream Format not found
DEMUXER: freeing demuxer at 0x9be1cc8
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 0 p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0 MP3: 0, synced: 0
Not MPEG System Stream format... (maybe Transport Stream?)
s->pos=23E newpos=0 new_bufpos=0 buflen=0
stream_seek: WARNING! Can't seek to 0x0 !
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 0 p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0 MP3: 0, synced: 3
Not MPEG System Stream format... (maybe Transport Stream?)
s->pos=23E newpos=0 new_bufpos=0 buflen=0
stream_seek: WARNING! Can't seek to 0x0 !
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
head_check failed
head_check failed
head_check failed
[…, repeated several times]
head_check failed
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
ty:ty processing
s->pos=23E newpos=FFFFFFFFFFFFF800 new_bufpos=FFFFFFFFFFFFFFFF buflen=0
Seek failed
ty:ty header size 0
ty:ty which Chunk 0
ty:file end_pos 23e

ty:wanted current offset fffffffffffff800
s->pos=FFFFFFFFFFFFF800 newpos=0 new_bufpos=0 buflen=0
stream_seek: WARNING! Can't seek to 0x0 !
ds_fill_buffer: EOF reached (stream: video)
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
LAVF_check: no clue about this gibberish!
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
Checking for DV
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
demux_aac_probe, failed to detect an AAC stream
DEMUXER: freeing demuxer at 0x9be1cc8
s->pos=0 newpos=0 new_bufpos=0 buflen=0
DEMUXER: freeing demuxer at 0x9be1cc8

* uninit(0x48)

[uninit getch2?]
Config poped level=2
Config poped level=1

* uninit(0x80)
vo: x11 uninit called but X11 not initialized..

Exiting... (End of file)
max framesize was 0 bytes
---

Extracting one of the RTSP URLs [2] manually works though. I am attaching the SMIL file to this report.

It would be nice, if this problem can be resolved or the reason found.

Thanks,

Paul

[1] http://www.berlin888.de/live_hoeren.html
[2] rtsp://stream2.rbb-online.de/encoder/radioberlin-888-live.ra

Attachments (1)

live.smil (574 bytes) - added by paulepanter@… 9 years ago.
SMIL file with RTSP streams.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by paulepanter@…

SMIL file with RTSP streams.

comment:1 Changed 9 years ago by paulepanter@…

comment:2 Changed 9 years ago by r_togni@…

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.