Opened 7 years ago

Closed 7 years ago

#1634 closed defect (fixed)

GUI crashes on program start (interrupted by signal 11 in module: unknown)

Reported by: amk@… Owned by: reimar
Priority: normal Component: GUI
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When starting the GUI version of mplayer (gmplayer), it sometimes
(chances are 50:50) crashes during initialization of its GUI components
with this message:

MPlayer interrupted by signal 11 in module: unknown

Default configuration, command line is:
gmplayer -skin mplayer_red does_not_exist

That means, it doesn't depend on any specific video file. It crashes
before it even touches the video file. It doesn't crash always. Maybe
a timing issue during the GUI initialization. It doesn't depend on
CPU architecture (same bug on AMD Dual Core and Intel with HT).

The non-GUI version (mplayer) runs fine. So it looks like a problem
with the GUI itself, not with the video output in general.

I could not reproduce the crash when running within "gdb".

I will attach to verbose output logs, one when the GUI version runs
fine, and one when the GUI version crashes. Maybe it helps to see
where it fails.

System is Fedora Linux release 12 (x86, 32 bit). MPlayer did not
crash on old Fedora 10 a few months ago. Appended is the stuff
recommended in "bugreports_what.html".

uname -a

Linux linux 2.6.31.12-174.2.3.fc12.i686.PAE #1 SMP Mon Jan 18 20:06:44 UTC 2010 i686 athlon i386 GNU/Linux

ls -l /lib/libc[.-]*

-rwxr-xr-x. 1 root root 2400428 2010-01-04 15:29 /lib/libc-2.11.1.so*
lrwxrwxrwx. 1 root root 14 2010-01-13 12:01 /lib/libc.so.6 -> libc-2.11.1.so*

gcc -v

Using built-in specs.
Target: i686-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch=i686 --build=i686-redhat-linux
Thread model: posix
gcc version 4.4.2 20091222 (Red Hat 4.4.2-20) (GCC)

ld -v

GNU ld version 2.19.51.0.14-34.fc12 20090722

as --version

GNU assembler version 2.19.51.0.14-34.fc12 20090722
Copyright 2008 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `i686-redhat-linux'.

Window Manager: fvwm 2.5.28

xdpyinfo | grep "depth of root"
depth of root window: 24 planes

gtk2 2.18.6

glib2 2.22.3

nVidia GeForce? 6150
X.Org X Server 1.7.4
nouveau 0.0.15-19.20091105gite1c2efd

ldd /usr/local/bin/gmplayer

linux-gate.so.1 => (0x00b88000)
libncurses.so.5 => /lib/libncurses.so.5 (0x00302000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x006f5000)
libz.so.1 => /lib/libz.so.1 (0x0018d000)
libmng.so.1 => /usr/lib/libmng.so.1 (0x008b3000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00e7f000)
libopenjpeg.so.2 => /usr/lib/libopenjpeg.so.2 (0x00523000)
libungif.so.4 => /usr/lib/libungif.so.4 (0x008a8000)
libasound.so.2 => /lib/libasound.so.2 (0x005b0000)
libdl.so.2 => /lib/libdl.so.2 (0x00110000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00115000)
libcdda_interface.so.0 => /usr/local/lib/libcdda_interface.so.0 (0x00857000)
libcdda_paranoia.so.0 => /usr/local/lib/libcdda_paranoia.so.0 (0x00eac000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x001a0000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00543000)
libbz2.so.1 => /lib/libbz2.so.1 (0x0012f000)
libmad.so.0 => /usr/local/lib/libmad.so.0 (0x002ec000)
libspeex.so.1 => /usr/lib/libspeex.so.1 (0x0093e000)
libtheora.so.0 => /usr/lib/libtheora.so.0 (0x00273000)
libogg.so.0 => /usr/lib/libogg.so.0 (0x00f4a000)
libmpcdec.so.5 => /usr/lib/libmpcdec.so.5 (0x009b1000)
libbs2b.so.0 => /usr/lib/libbs2b.so.0 (0x00368000)
libm.so.6 => /lib/libm.so.6 (0x00145000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00843000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x0036e000)
libXss.so.1 => /usr/lib/libXss.so.1 (0x00d1b000)
libXv.so.1 => /usr/lib/libXv.so.1 (0x00bd2000)
libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x00c40000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x002e3000)
libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00140000)
libXxf86dga.so.1 => /usr/lib/libXxf86dga.so.1 (0x0016f000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x0071d000)
libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x009be000)
libartsc.so.0 => /usr/lib/libartsc.so.0 (0x00e5a000)
libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x0083c000)
libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00a89000)
librt.so.1 => /lib/librt.so.1 (0x006ec000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00a8e000)
libpulse.so.0 => /usr/lib/libpulse.so.0 (0x004a6000)
libjack.so.0 => /usr/lib/libjack.so.0 (0x00234000)
libmp3lame.so.0 => /usr/local/lib/libmp3lame.so.0 (0x007ae000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00fac000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00c42000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x0024f000)
libgio-2.0.so.0 => /lib/libgio-2.0.so.0 (0x00d1e000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x002aa000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00f5c000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00175000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00dcf000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x0069b000)
libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00955000)
libc.so.6 => /lib/libc.so.6 (0x046d3000)
libtinfo.so.5 => /lib/libtinfo.so.5 (0x00325000)
libgif.so.4 => /usr/lib/libgif.so.4 (0x00181000)
liblcms.so.1 => /usr/lib/liblcms.so.1 (0x00866000)
/lib/ld-linux.so.2 (0x00f8c000)
libexpat.so.1 => /lib/libexpat.so.1 (0x0033e000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x01439000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x004ec000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00f23000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x0018a000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x0026e000)
libdrm.so.2 => /usr/lib/libdrm.so.2 (0x002d3000)
libpulsecommon-0.9.21.so => /usr/lib/libpulsecommon-0.9.21.so (0x00bd7000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x0050a000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00578000)
libXtst.so.6 => /usr/lib/libXtst.so.6 (0x002e6000)
libwrap.so.0 => /lib/libwrap.so.0 (0x00efe000)
libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0x09aa5000)
libasyncns.so.0 => /usr/lib/libasyncns.so.0 (0x00512000)
libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00b89000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00518000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00592000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x005a0000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00826000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x002df000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00925000)
libselinux.so.1 => /lib/libselinux.so.1 (0x00a61000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x04cf5000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00540000)
libuuid.so.1 => /lib/libuuid.so.1 (0x005a8000)
libnsl.so.1 => /lib/libnsl.so.1 (0x00cf7000)
libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x00eb4000)
libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x07e8b000)
libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x01520000)
libcap-ng.so.0 => /lib/libcap-ng.so.0 (0x00f0e000)

Attachments (2)

mplayer-crash11-output-okayverbose.txt (23.4 KB) - added by amk@… 7 years ago.
Console output when GMPlayer does not crash
mplayer-crash11-output-failverbose.txt (10.4 KB) - added by amk@… 7 years ago.
Console output when GMPlayer crashes with signal 11

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by amk@…

Console output when GMPlayer does not crash

comment:1 Changed 7 years ago by amk@…

Changed 7 years ago by amk@…

Console output when GMPlayer crashes with signal 11

comment:2 Changed 7 years ago by amk@…

comment:3 Changed 7 years ago by reimar

The GUI is unmaintained, so there's not much hope it will be fixed.
Anyway, does it also happen if you use a different skin?
Also try updating, there may have been an alignment issue that is now fixed.

comment:4 Changed 7 years ago by amk@…

Thanks for the effort, updated a couple of minutes ago, but it still crashes.
Also doesn't seem to depend on a specific skin (tried a couple of different ones).

Is it really true that the GUI is unmaintained? I'm confused. What exactly
does this mean? MPlayer should only be used by text console and keyboard?
MPlayer is such a popular video player. Come on, you can't be serious,
there must be some kind of nice GUI. And although it may be unmaintained,
I really like the GUI of GMPlayer very much. Excellent look and feel.
Never had any problems. Does exactly what I want and offers all I need.
Great thing! Unfortunately, Fedora 12 doesn't seem to like it. *sigh*

comment:5 Changed 7 years ago by reimar

Try updating again.
If it does not work, move your configuration out of the way and/or try with -fstype none
The officially recommended GUI is SMPlayer.
The GUI being umaintained is supposed to mean "please try to find a different GUI that you like, because every time we look that the gmplayer code we feel a very strong urge to delete it and we probably won't be able to resist it one day".

comment:6 Changed 7 years ago by amk@…

It looks like you got it! Haven't had a single crash until now.
Although it's not officially supported, I'd like to thank you
very, very much for finding and fixing this little bugger.

I've also tried SMPlayer as you recommended. Amazingly lots of
features. Unfortunately, it's not really designed to run the movie and
the control panel in different windows (it's possible, but then they
behave more like two different applications). And I really miss
the skins. ;-)

Well, I promise to give SMPlayer a try. However, thanks a lot
for fixing the old GUI (I still think it's really great) so that
users like me don't have to switch all at once and have got some
extra time to get used to SMPlayer.

comment:7 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be fixed

comment:8 Changed 7 years ago by amk@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

MPlayer worked perfectly until the SVN snapshot from 2010-02-27 at least.
Haven't updated MPlayer since then.

Yesterday I downloaded MPlayer 1.0rc3 (dated 2010-05-30), and this old bug
is there again. Just like it had never been fixed.

I know the internal GUI is unmaintained... but maybe you could have a look
what happened here. Maybe there's something wrong with 1.0rc3 in general?

comment:9 Changed 7 years ago by amk@…

Just downloaded the current SVN snapshot, and there the GUI works great.
The MPlayer 1.0rc3 archive seems to be kind of weird.

comment:10 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

What's wrong is that rc3 is based on ancient code. This is not the only bugfix by far that's not included.

Note: See TracTickets for help on using tickets.