Opened 9 years ago

Closed 9 years ago

#1665 closed defect (duplicate)

"-vo gl" don't work if "-af ladspa" is used.

Reported by: lorefice2@… Owned by: reimar
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer SVN-r30881-4.4.3

commandline:
#mplayer -vo gl -af ladspa=/usr/lib/ladspa/fast_lookahead_limiter_1913.so:fastLookaheadLimiter:10:0:2 myvideo.avi

mplayer error message:


..
Starting playback...
[mpeg4 @ 0x8a5d0e0]Invalid and inefficient vfw-avi packed B frames detected
Movie-Aspect is 1,82:1 - prescaling to correct movie aspect.
VO: [gl] 640x352 => 640x352 Planar YV12
[gl] Error compiling fragment program, make sure your card supports
[gl] GL_ARB_fragment_program (use glxinfo to check).
[gl] Error message:

line 2, column 272: error: expected '}'

line 2, column 330: error: expected '}'
line 2, column 388: error: expected '}'
line 2, column 448: error: expected '}'

at , 1,164000

trying with another audio filter (extrastereo) works just fine.

Attachments (2)

withladspa.txt (53.1 KB) - added by lorefice2@… 9 years ago.
mplayer failing on -vo gl with -af ladspa
withoutladspa.txt (46.9 KB) - added by lorefice2@… 9 years ago.
The Same, without -af ladspa; -vo gl now works

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by reimar

Please give the full -v output (most importantly it should include the generated fragment program).
Also the output with r30882 would be a bit better.

comment:2 Changed 9 years ago by reimar

  • Owner changed from beastd to reimar

comment:3 Changed 9 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce on Ubuntu 9.10 32 bit, valgrind does not have any complaints either.
You will have to provide more information, like the full -v log, and a sample file (if it happens with any, choose one from http://samples.mplayerhq.hu), testing with different -ao and running under valgrind might be a good idea as well.

Changed 9 years ago by lorefice2@…

mplayer failing on -vo gl with -af ladspa

comment:4 Changed 9 years ago by lorefice2@…

Changed 9 years ago by lorefice2@…

The Same, without -af ladspa; -vo gl now works

comment:5 Changed 9 years ago by lorefice2@…

comment:6 Changed 9 years ago by lorefice2@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I just compiled the latest mplayer-svn: MPlayer SVN-r30929
Here's the output (including fragment program) from a test file i picked from:
http://samples.mplayerhq.hu/avi/test_vodei.avi

Command line:
mplayer -vo gl -af ladspa=/usr/lib/ladspa/fast_lookahead_limiter_1913.so:fastLookaheadLimiter:10:0:2 ./test_vodei.avi -v -v

And another without ladspa:
mplayer -vo gl ./test_vodei.avi -v -v

I've attached both outputs on previous posts.

comment:7 Changed 9 years ago by lorefice2@…

I've just spotted the problem, and this seems to be related to bug:
http://bugzilla.mplayerhq.hu/show_bug.cgi?id=1334
(which i reported long time ago and it is still unfixed.)
If you see the generated fragment program, all points are translated to commas.
Any hope it will be fixed in a way ladspa filters could still be used, please?

comment:8 Changed 9 years ago by reimar

  • Resolution set to duplicate
  • Status changed from reopened to closed

Those are indeed the same thing.

* This bug has been marked as a duplicate of bug 1334 *

Note: See TracTickets for help on using tickets.