Opened 9 years ago

Closed 9 years ago

#1691 closed defect (worksforme)

mplayer crashes when playing any WMV

Reported by: jimoe@… Owned by: reimar
Priority: very important Component: core
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

MPlayer SVN-r31136-4.4 (C) 2000-2010 MPlayer Team

Not much to say: mplayer crashes every time I attempt to play a WMV. Test WMVs that previously worked no longer do. MP3s are okay.


Linux sma-station14l 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

-rwxr-xr-x 1 root root 1430104 2010-01-27 05:39 /lib/libc-2.10.1.so*
lrwxrwxrwx 1 root root 14 2010-02-12 13:08 /lib/libc.so.6 -> libc-2.10.1.so*

gcc -v

Using built-in specs.
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.4 --enable-ssp --disable-libssp --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --program-suffix=-4.4 --enable-linux-futex --without-system-libunwind --with-arch-32=i586 --with-tune=generic --build=x86_64-suse-linux
Thread model: posix
gcc version 4.4.1 [gcc-4_4-branch revision 150839] (SUSE Linux)

ld -v

GNU ld (GNU Binutils; openSUSE 11.2) 2.19.51.20090527-10.26.4


Attachments (2)

mplayer.log (7.5 KB) - added by jimoe@… 9 years ago.
Log file from crashed instance.
mplayer.bug (80.6 KB) - added by jimoe@… 9 years ago.
gdb output for crashed instance.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by jimoe@…

Log file from crashed instance.

comment:1 Changed 9 years ago by jimoe@…

Changed 9 years ago by jimoe@…

gdb output for crashed instance.

comment:2 Changed 9 years ago by jimoe@…

comment:3 Changed 9 years ago by reimar

Did you try a "make distclean" or a new checkout?
This looks like a broken compilation, possibly due to old and new code being mixed up.

comment:4 Changed 9 years ago by jimoe@…

  • Resolution set to worksforme
  • Status changed from new to closed

Yes, that was it. I forgot about that step.

Note: See TracTickets for help on using tickets.