Opened 9 years ago

Last modified 8 years ago

#1702 closed defect (worksforme)

revision 31186 too few arguments to function 'ff_parse_expr'

Reported by: kuh3h3@… Owned by: reimar
Priority: normal Component: vf
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

cc -MD -MP -Wstrict-prototypes -Wmissing-prototypes -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -W -Wall -O2 -march=native -mtune=native -pipe -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -Ilibdvdread4 -I. -D_REENTRANT -I/usr/include/directfb -I/usr/include/ -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D_REENTRANT -I/usr/include/freetype2 -I/usr/include/bs2b -DHAVE_STRUCT_SOCKADDR_STORAGE -I/usr/include/dirac -I/usr/include/schroedinger-1.0 -I/usr/include/orc-0.4 -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -c -o libmpcodecs/vf_geq.o libmpcodecs/vf_geq.c
libmpcodecs/vf_geq.c: In function 'vf_open':
libmpcodecs/vf_geq.c:175: warning: initialization from incompatible pointer type
libmpcodecs/vf_geq.c:176: warning: initialization from incompatible pointer type
libmpcodecs/vf_geq.c:177: warning: initialization from incompatible pointer type
libmpcodecs/vf_geq.c:178: warning: initialization from incompatible pointer type
libmpcodecs/vf_geq.c:182: warning: passing argument 5 of 'ff_parse_expr' from incompatible pointer type
libmpcodecs/vf_geq.c:182: warning: passing argument 6 of 'ff_parse_expr' from incompatible pointer type
libmpcodecs/vf_geq.c:182: warning: passing argument 7 of 'ff_parse_expr' makes integer from pointer without a cast
libmpcodecs/vf_geq.c:182: error: too few arguments to function 'ff_parse_expr'
make: * [libmpcodecs/vf_geq.o] error 1

Change History (1)

comment:1 Changed 8 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

what gcc version? closing bug as it works for me and everyone else.

Note: See TracTickets for help on using tickets.