Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#196 closed defect (wontfix)

change GUI language based on localization variables do not work

Reported by: superandrzej@… Owned by: diego@…
Priority: normal Component: DOCS
Version: 1.0pre6 Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I compiled Mplayer with the --language=all option
Then I was trying to use GUI in other language than English.

For example I have the following variables set
export LANG=pl
export LC_ALL=pl_PL

based on ./configure –help I even set an extra variable
export LINGUAS=pl

but with no luck. GUI was in English.

The only way to have Polish GUI was to compile Mplayer with --language=pl option

Is this a bug? Or am I doing something wrong?

regards

Andrzej

Change History (3)

comment:1 Changed 15 years ago by reimar

  • Component changed from GUI to DOCS

The binary will always contain only one language. Those options just make a
difference on which manpages are installed and which HTML docs are created AFAIK.
I don't think this will be changed soon if at all...
As this concerns translations (and not only the Gui) I assign this to DOCS.

btw.: Why on earth was the Gui component assigned to me?? Because I loathe it so
much??

comment:2 Changed 15 years ago by reimar

  • Owner changed from Reimar.Doeffinger@… to diego@…

comment:3 Changed 15 years ago by diego@…

  • Cc Reimar.Doeffinger@… added
  • Resolution set to wontfix
  • Status changed from new to closed

Fixing this would require switching to gettext or some other major surgery. I
don't see this happening anytime soon, thus marking WONTFIX.

Reimar, you got the GUI component because you hacked it quite a bit ;-P

Note: See TracTickets for help on using tickets.