Opened 8 years ago

Closed 8 years ago

#2005 closed defect (fixed)

ffc93 corrupted video output

Reported by: onemda@… Owned by: reimar
Priority: if idle Component: vo
Version: HEAD Severity: minor
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

avplay from libav plays it fine

MPlayer UNKNOWN-4.2.2 (C) 2000-2011 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 2
CPU: Intel(R) Celeron(R) M processor 1.70GHz (Family: 6, Model: 13, Stepping: 8)
extended cpuid-level: 8
extended cache-info: 67125312
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 CMOV
get_path('codecs.conf') -> '/home/r/.mplayer/codecs.conf'
Reading optional codecs config file /home/r/.mplayer/codecs.conf: No such file or directory
Reading optional codecs config file /usr/local/etc/mplayer/codecs.conf: No such file or directory
Using built-in default codecs.conf.
get_path('font/font.desc') -> '/home/r/.mplayer/font/font.desc'
font: can't open file: /home/r/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Configuration:
CommandLine?: '-msglevel' 'all=6' 'tun.c93'
Using nanosleep() timing
get_path('input.conf') -> '/home/r/.mplayer/input.conf'
Parsing input config file /home/r/.mplayer/input.conf
Input config file /home/r/.mplayer/input.conf parsed: 103 binds
get_path('tun.c93.conf') -> '/home/r/.mplayer/tun.c93.conf'
Loading extension-related profile 'vo.xv'

Playing tun.c93.
get_path('sub/') -> '/home/r/.mplayer/sub/'
[file] File size is 4012032 bytes
STREAM: [file] tun.c93
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: Interplay C93
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename tun.c93 ext: .c93
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
AVS: avs_check_file - attempting to open file tun.c93
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 70243, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=256 size=905982979
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 87 p101: 76 p1B6: 0 p12x: 8 sli: 76 a: 23 b: 50 c: 0 idr: 0 sps: 0 pps: 0 PES: 26 MP3: 3375, synced: 0
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 87 p101: 76 p1B6: 0 p12x: 8 sli: 76 a: 23 b: 50 c: 0 idr: 0 sps: 0 pps: 0 PES: 26 MP3: 3375, synced: 0
==> Found video stream: 0
ds_fill_buffer: EOF reached (stream: video)
LAVF_check: Interplay C93
libavformat file format detected.
[c93 @ 0x8a36a20]err{or,}_recognition separate: 1; 1
[c93 @ 0x8a36a20]err{or,}_recognition combined: 1; 1
[pcm_u8 @ 0x8a36a20]err{or,}_recognition separate: 1; 1
[pcm_u8 @ 0x8a36a20]err{or,}_recognition combined: 1; 1
[c93 @ 0x89ced20]max_analyze_duration reached
==> Found video stream: 0
======= VIDEO Format ======

biSize 40
biWidth 320
biHeight 192
biPlanes 0
biBitCount 0
biCompression 1446197571='C93V'
biSizeImage 0

===========================
[lavf] stream 0: video (c93), -vid 0
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 1 (0x1)
Channels: 1
Samplerate: 16129
avg byte/sec: 16129
Block align: 1
bits/sample: 8
cbSize: 0
==========================================================================
[lavf] stream 1: audio (pcm_u8), -aid 0
LAVF: 1 audio and 1 video streams found
LAVF: build 3475968
VIDEO: [C93V] 320x192 0bpp 12.500 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:35 fourcc:0x56333943 size:320x192 fps:12.500 ftime:=0.0800
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports layers.
[x11] Using workaround for Metacity bugs.
[x11] Detected wm supports NetWM.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports FULLSCREEN state.
[x11] Current fstype setting honours FULLSCREEN ABOVE BELOW X atoms
[VO_XV] Using Xv Adapter #0 (ATI Radeon Video Overlay)
[xv common] Drawing colorkey manually.
[xv common] Using colorkey from Xv (0x00001e).
[xv common] Maximum source image dimensions: 2047x2047
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[c93 @ 0x8a36a20]err{or,}_recognition separate: 2; 1
[c93 @ 0x8a36a20]err{or,}_recognition combined: 2; 3
INFO: libavcodec init OK!
Selected video codec: [ffc93] vfm: ffmpeg (FFmpeg C93 Video)
==========================================================================
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
dec_audio: Allocating 2048 + 131072 = 133120 bytes for output buffer.
AUDIO: 16129 Hz, 1 ch, u8, 129.0 kbit/100.00% (ratio: 16129->16129)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
Building audio filter chain for 16129Hz/1ch/u8 -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 16129Hz/1ch/u8
[dummy] Was reinitialized: 16129Hz/1ch/u8
Trying every known audio driver...
ao2: 16129 Hz 1 chans u8
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: u8 (requested: u8)
audio_setup: using 1 channels (requested: 1)
audio_setup: using 16129 Hz samplerate (requested: 16129)
audio_setup: frags: 32/32 (256 bytes/frag) free: 8192
AO: [oss] 16129Hz 1ch u8 (1 bytes per sample)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 16129Hz/1ch/u8 -> 16129Hz/1ch/u8...
[dummy] Was reinitialized: 16129Hz/1ch/u8
[dummy] Was reinitialized: 16129Hz/1ch/u8
Starting playback...
Increasing filtered audio buffer size from 0 to 8704
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 320 x 192 (preferred colorspace: BGR 8-bit)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
VDec: using BGR 8-bit as output csp (no 0)
Movie-Aspect is 1.39:1 - prescaling to correct movie aspect.
VO Config (320x192->320x230,flags=0,'MPlayer',0x42475208)
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 9 -> 8
SwScaler?: reducing / aligning filtersize 1 -> 1
SwScaler?: reducing / aligning filtersize 9 -> 8
[swscaler @ 0x89c0260]BICUBIC scaler, from pal8 to yuv420p using MMX2
[swscaler @ 0x89c0260]320x192 -> 320x192
[swscaler @ 0x89c0260]lum srcW=320 srcH=192 dstW=320 dstH=192 xInc=65536 yInc=65536
[swscaler @ 0x89c0260]chr srcW=320 srcH=192 dstW=160 dstH=96 xInc=131072 yInc=131072
REQ: flags=0x437 req=0x0
VO: [xv] 320x192 => 320x230 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others
Xvideo image format: 0x41424752 (RGBA) packed
Xvideo image format: 0x54424752 (RGBT) packed
Xvideo image format: 0x32424752 (RGB2) packed
Xvideo image format: 0x0 ( ) packed
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x59565955 (UYVY) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x30323449 (I420) planar
using Xvideo port 63 for hw scaling
* [scale] Allocating mp_image_t, 320x192x8bpp BGR packed, 61440 bytes
* [vo] Allocating mp_image_t, 320x192x12bpp YUV planar, 92160 bytes
A: 8.9 V: 8.9 A-V: 0.003 ct: 0.081 0/ 0 2% 2% 0.1% 0 0
Uninit audio filters...
[libaf] Removing filter dummy
Uninit audio: pcm
Uninit video: ffmpeg
vo: uninit ...

Exiting... (Quit)

Change History (7)

comment:1 Changed 8 years ago by onemda@…

  • Version changed from unspecified to HEAD

comment:2 Changed 8 years ago by reimar

I'll need a sample file or something to test this...

comment:4 Changed 8 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed, cehoyos@ag.or.at

Fixed by Reimar

comment:5 Changed 8 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Sorry, this is still reproducible with current svn (r34305).

comment:6 Changed 8 years ago by reimar

Huh? It is not reproducible for me with latest SVN.

comment:7 Changed 8 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from reopened to closed

Now really fixed (r34306).

Note: See TracTickets for help on using tickets.