Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#205 closed defect (duplicate)

Getting IO errors while trying to dump a realaudio stream

Reported by: pvdharanjm@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I seem to be getting this error while trying to read and dump a realaudio
stream. I cannot deduce anymore rootcause of the issue from the cryptic error
message. It will be good if the error message prints more than Cannot dump this
stream - no 'fd' available.
which seems to be probably rooted to some stdio library related error.

I tried runnin this with root permisision to ensure there are not permission
problem. I googled and searched bug reports, forums etc.

NPR Stream:
bash-2.05b# /usr/bin/mplayer -dumpstream -dumpfile r.wav
"rtsp://real.npr.na-central.speedera.net/real.npr.na-central/news2a.smil"
MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing rtsp://real.npr.na-central.speedera.net/real.npr.na-central/news2a.smil.
Resolving real.npr.na-central.speedera.net for AF_INET...
Connecting to server real.npr.na-central.speedera.net[63.210.103.14]:554 ...
Connection timeout
Resolving real.npr.na-central.speedera.net for AF_INET...
Connecting to server real.npr.na-central.speedera.net[63.210.103.14]:7070 ...
Connection timeout
Not a Realmedia rtsp url. Trying standard rtsp protocol.
Connected to server: real.npr.na-central.speedera.net
Cannot dump this stream - no 'fd' available.

Exiting... (Fatal error)

BBC Stream:

bash-2.05b# /usr/bin/mplayer -dumpstream "rtsp://rmlivev8.bbc.net.uk/farm/*/ev7
/live24/bbc7/live/bbc7_dsat_g2.ra"
MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Playing rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/bbc7/live/bbc7_dsat_g2.ra.
Resolving rmlivev8.bbc.net.uk for AF_INET...
Connecting to server rmlivev8.bbc.net.uk[212.58.240.94]:554 ...
Connection timeout
Resolving rmlivev8.bbc.net.uk for AF_INET...
Connecting to server rmlivev8.bbc.net.uk[212.58.240.94]:7070 ...
Connection timeout
Not a Realmedia rtsp url. Trying standard rtsp protocol.
Connected to server: rmlivev8.bbc.net.uk
Cannot dump this stream - no 'fd' available.

Exiting... (Fatal error)

Change History (2)

comment:1 Changed 14 years ago by r_togni@…

If you look at the previous messages, you'll see that the conection timeout on
both 554 and 7070 ports. For more verbose output (probably nothing important
anywayin your case) use mplayer -v

Can you connect to those ports? maybe a firewall problem?

The bbc url works here.
The npr doesn't, but for different reason, mplayer still doesn't support
playlists (the .smil file) over realrtsp.
But i don't get the timeout on those urls.

BTW npr is the source of the weirdest streams (techincally) i ever found.

comment:2 Changed 14 years ago by r_togni@…

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate, the bbc stream is not an mplayer problem; about the smil
over rtsp there is already a report

* This bug has been marked as a duplicate of 152 *

Note: See TracTickets for help on using tickets.