Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2067 closed defect (fixed)

lavdopts threads produce big video glitches

Reported by: subjunk@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: critical
Keywords: VERIFIED Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

This started happening between r34890 and r34900.
It happens with all videos I have tested.

Using any value for lavdopts threads causes big horizontal lines to appear on the video which are sections of other frames. See screenshot attached.
lavcopts threads works fine, it is just lavdopts.

Command line to produce the bug:
mencoder input.mkv -oac copy -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=8 -lavdopts debug=0 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=8 -o out.mpeg

Take lavcopts threads away and it works fine:
mencoder input.mkv -oac copy -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0 -lavdopts debug=0 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=8 -o out.mpeg

Attachments (1)

out.mpeg_snapshot_00.08_[2012.05.20_12.38.33].png (297.8 KB) - added by subjunk@… 7 years ago.
Bug

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by subjunk@…

Bug

comment:1 Changed 7 years ago by reimar

Is this reproducible with MPlayer somehow or only with mencoder?
Also which versions have you tested? r34900 was known broken, r34912 is the first with no known issues.

comment:2 Changed 7 years ago by subjunk@…

Sorry, I should have included that information.
It happened with the latest version at the time of submission (r34923) and still happens with the latest build (r34933).

r34900 also had a different bug where the video went very fast, and that has been fixed, but the video glitches are there. It's possible that the bug was introduced after r34900 but before r34910, because it was hard to tell if r34900 had this bug on top of the speed bug.
So with that taken into account, r34890 definitely does not have this bug and r34910 definitely does have this bug (I tested by 10 revisions at a time)

It happens only with MEncoder.

comment:3 Changed 7 years ago by reimar

Actually I believe the same issue appears with mplayer with -vo x11, however not with -vo gl.

comment:4 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

At least for MPlayer I believe this is fixed in r34952.
I would appreciate if you could test and verify it is indeed fixed also for mencoder.

comment:5 Changed 7 years ago by subjunk@…

In MEncoder it seems to be fixed but replaced with another bug.
Now only roughly 2-4 seconds of video is output before crashing and the error is:

"Ran out of numbered images, expect crash. Filter before lavc is broken".

This bug occurs without multithreading.
It does not happen with MPlayer, just MEncoder.

Do you want me to create a new issue for it or keep using this one?

comment:6 Changed 7 years ago by subjunk@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I have confirmed that it was the fix for this issue (r34952) that caused the new bug; I compiled r34962 without r34952 and the whole video is encoded (but of course it brings back the original bug)

comment:7 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

It's a bit annoying that it can't print the right filter directly, but as the message said it was a broken video filter - so not really mencoder-specific.
In this case, it was the automatically inserted expand filter that was broken (and is fixed now).

comment:8 Changed 7 years ago by subjunk@…

Fix confirmed, thanks :)

comment:9 Changed 7 years ago by subjunk@…

  • Keywords VERIFIED added
Note: See TracTickets for help on using tickets.