Opened 7 years ago

Closed 7 years ago

#2083 closed defect (invalid)

screenshot PNGs have black area at bottom, -vo png output does not

Reported by: aaron@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

i like to hit 'S' to take screenshots while watching TV. since i started watching digital broadcasts i noticed that all the PNGs i got were black on the bottom 40% or so; one is attached. interestingly, -vo png does not have the same problem, but i can't bother to run a whole new mplayer with an exact -ss offset every time i want a screenshot.

HEAD today is SVN-r35118-4.6.

Attachments (2)

shot0001.png (827.4 KB) - added by aaron@… 7 years ago.
problem screenshot
file_2083.txt (15.5 KB) - added by aaron@… 7 years ago.
verbose console

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by aaron@…

problem screenshot

comment:1 Changed 7 years ago by cehoyos

  • Cc cehoyos@… added

(I am unable to reproduce a problem here using dvb input.)
Please provide your command line and complete, uncut console output.

Changed 7 years ago by aaron@…

verbose console

comment:2 Changed 7 years ago by aaron@…

console output when problem is exhibited. source is video previously recorded from dvb://.

comment:3 Changed 7 years ago by cehoyos

The MPlayer version you are testing is intentionally broken (by the distributor), it contains several hundred known regressions, some of them security relevant, and therefore cannot be supported here.

Could you test current MPlayer svn head? See http://www.mplayerhq.hu/design7/dload.html

comment:4 Changed 7 years ago by aaron@…

  • Resolution set to invalid
  • Status changed from new to closed

i'm so sorry to waste your time. i got the debian one and the one i compiled more recently confused - the latter does fix this. thanks for your help!

Note: See TracTickets for help on using tickets.