Opened 4 years ago

Closed 3 years ago

#2181 closed defect (fixed)

-vo null has broken for audio files with embedded covers

Reported by: birdie Owned by:
Priority: highest Component: vo
Version: HEAD Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

I have several audio files with embedded JPG/PNG covers. When I'm trying to play them using -vo null MPlayer crashes:

% mplayer -vo null input.m4a

--- cut ---

Starting playback...
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
demux_lavf_fill_buffer()
Increasing filtered audio buffer size from 0 to 69632
vd_ffmpeg data: e0ffd8ff, 464a1000, 1004649, 2c010101
[mjpeg @ 0xb75557a0]marker=d8 avail_size_in_buf=23687
[mjpeg @ 0xb75557a0]marker parser used 0 bytes (0 bits)
[mjpeg @ 0xb75557a0]marker=e0 avail_size_in_buf=23685
[mjpeg @ 0xb75557a0]marker parser used 16 bytes (128 bits)
[mjpeg @ 0xb75557a0]marker=e2 avail_size_in_buf=23667
[mjpeg @ 0xb75557a0]marker parser used 3159 bytes (25272 bits)
[mjpeg @ 0xb75557a0]marker=db avail_size_in_buf=20505
[mjpeg @ 0xb75557a0]index=0
[mjpeg @ 0xb75557a0]qscale[0]: 1
[mjpeg @ 0xb75557a0]marker parser used 67 bytes (536 bits)
[mjpeg @ 0xb75557a0]marker=db avail_size_in_buf=20436
[mjpeg @ 0xb75557a0]index=1
[mjpeg @ 0xb75557a0]qscale[1]: 2
[mjpeg @ 0xb75557a0]marker parser used 67 bytes (536 bits)
[mjpeg @ 0xb75557a0]marker=c0 avail_size_in_buf=20367
[mjpeg @ 0xb75557a0]sof0: picture: 600x600
[mjpeg @ 0xb75557a0]component 0 1:1 id: 0 quant:0
[mjpeg @ 0xb75557a0]component 1 1:1 id: 1 quant:1
[mjpeg @ 0xb75557a0]component 2 1:1 id: 2 quant:1
[mjpeg @ 0xb75557a0]pix fmt id 11111100
[ffmpeg] aspect_ratio: 1.000000
VDec: vo config request - 600 x 600 (preferred colorspace: Planar 444P)
Trying filter chain: vo
vo_debug: query(Planar 444P) returned 0x1 (i=0)
vo_debug: query(Planar 444P) returned 0x1 (i=0)
vo_debug: codec query_format(Planar 422P) returned FALSE
vo_debug: codec query_format(Planar 440P) returned FALSE
vo_debug: codec query_format(Packed YUY2) returned FALSE
vo_debug: codec query_format(Planar YV12) returned FALSE
vo_debug: codec query_format(Planar I420) returned FALSE
vo_debug: codec query_format(Planar IYUV) returned FALSE
vo_debug: codec query_format(BGR 24-bit) returned FALSE
vo_debug: codec query_format(RGB 24-bit) returned FALSE
vo_debug: codec query_format(Planar Y800) returned FALSE
VDec: using Planar 444P as output csp (no 0)
Movie-Aspect is 1.00:1 - prescaling to correct movie aspect.
VO Config (600x600->600x600,flags=0,'MPlayer',0x50343434)
VO: [null] 600x600 => 600x600 Planar 444P
VO: Description: Null video output
VO: Author: Aaron Holtzman <aholtzma@ess.engr.uvic.ca>
using IP
*** [vo] Allocating mp_image_t, 608x608x24bpp YUV planar, 1108992 bytes
(imgfmt: 50343434, planes: 0xb2350020,0xb2404820,0xb23aa420 strides: 608,608,608, chroma: 608x608, shift: h:0,v:0)
[mjpeg @ 0xb75557a0]marker parser used 17 bytes (136 bits)
[mjpeg @ 0xb75557a0]marker=c4 avail_size_in_buf=20348
[mjpeg @ 0xb75557a0]class=0 index=0 nb_codes=11
[mjpeg @ 0xb75557a0]marker parser used 30 bytes (240 bits)
[mjpeg @ 0xb75557a0]marker=c4 avail_size_in_buf=20316
[mjpeg @ 0xb75557a0]class=1 index=0 nb_codes=211
[mjpeg @ 0xb75557a0]marker parser used 89 bytes (712 bits)
[mjpeg @ 0xb75557a0]marker=c4 avail_size_in_buf=20225
[mjpeg @ 0xb75557a0]class=0 index=1 nb_codes=7
[mjpeg @ 0xb75557a0]marker parser used 26 bytes (208 bits)
[mjpeg @ 0xb75557a0]marker=c4 avail_size_in_buf=20197
[mjpeg @ 0xb75557a0]class=1 index=1 nb_codes=241
[mjpeg @ 0xb75557a0]marker parser used 50 bytes (400 bits)
[mjpeg @ 0xb75557a0]escaping removed 67 bytes
[mjpeg @ 0xb75557a0]marker=da avail_size_in_buf=20145
[mjpeg @ 0xb75557a0]component: 0
[mjpeg @ 0xb75557a0]component: 1
[mjpeg @ 0xb75557a0]component: 2
[mjpeg @ 0xb75557a0]marker parser used 20077 bytes (160610 bits)
[mjpeg @ 0xb75557a0]marker=d9 avail_size_in_buf=0
[mjpeg @ 0xb75557a0]decode frame unused 0 bytes


MPlayer interrupted by signal 11 in module: filter video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

MPlayer SVN-r36986-4.7.3

Patches should be submitted to the mplayer-dev-eng mailing list and not this bug tracker.

Attachments (1)

1.m4a (967.4 KB) - added by birdie 4 years ago.
Sample file

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by birdie

Sample file

comment:1 Changed 4 years ago by birdie

Still broken in today's SVN snapshot:

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()

MPlayer SVN-r37183

comment:2 Changed 3 years ago by compn

i think the manual specifically says you need -vo null -vc null for it to work. and using -vc null works for me.

but i agree it shouldnt crash and is a bug.

comment:3 Changed 3 years ago by reimar

Is this still reproducible? It does not crash for me with latest SVN.

comment:4 Changed 3 years ago by birdie

  • Resolution set to fixed
  • Status changed from new to closed

Indeed fixed.

Note: See TracTickets for help on using tickets.