Opened 6 years ago

Closed 5 years ago

#2191 closed defect (fixed)

UT-Video 4:2:2 support fails due to FOURCC

Reported by: 4Selur@… Owned by:
Priority: normal Component: libavcodec
Version: unspecified Severity: blocker
Keywords: ULH2 ut-video Cc:
Blocked By: Blocking:
Reproduced by developer: yes Analyzed by developer: no

Description

Summary of the bug:

MPlayer fails to playback 4:2:2 UT-Video which uses the FOURCC ULH2.

How to reproduce:

mplayer "UT-422~1.AVI" -forcedsubsonly -v
m ffmpeg -nosub -noautosub -fps 50  -vo direct3d -lavdopts threads=1  -mc 0 -nosound

MPlayer SVN-r37218-4.9.0 (C) 2000-2014 MPlayer Team

Playing C:\Users\Selur\DOWNLO~1\UT-422~1.AVI.
libavformat version 55.42.100 (internal)
AVI file format detected.
[aviheader] Video stream found, -vid 0
VIDEO:  [ULH2]  1920x1080  24bpp  50.000 fps  981208.8 kbps (119776.5 kbyte/s)
==========================================================================
Trying to force video codec driver family ffmpeg...
Cannot find codec matching selected -vo and video format 0x32484C55.
==========================================================================


Exiting... (End of file)

sample file: https://mega.co.nz/#!UdEhjZCZ!_SMiU-Z3bAnH9tBvwh1OsmO-wr_YqWm9i44C11R4YGQ

Since ffplay/ffmpeg&libav in general support the content and it seems to be identified properly, the problem seem to be that fourcc 0x32484C55 isn't associated to the ffutvideo codec.

Change History (5)

comment:1 Changed 6 years ago by compn

should be fixed. thanks.

comment:2 Changed 5 years ago by 4Selur@…

Analog problem happens with ut-video which has a ULH0 fourcc:

VIDEO: [ULH0] 1920x1080 24bpp 25.000 fps 278453.4 kbps (33990.9 kbyte/s)

Clip info:

Creation Date: 2014-06-29T17:56:33+02:00
Software: Adobe Premiere Pro CC (Windows)

==========================================================================
Trying to force video codec driver family ffmpeg...
Cannot find codec matching selected -vo and video format 0x30484C55.
==========================================================================

same problem: not supported fourcc

comment:3 Changed 5 years ago by compn

are there any other fourccs which utvideo uses ?
added ULH0 and ULH1 to mplayer/etc/codecs.conf

comment:4 Changed 5 years ago by 4Selur@…

According to the current read me of the UT Video Codec Suite (http://umezawa.dyndns.info/archive/utvideo/utvideo-14.2.0-readme.en.html)
only the following FOURCCs are used:
ULRA, ULRG, ULY2, ULY0, ULH2, ULH0, UQY2
so there is no ULH1 ;)

comment:5 Changed 5 years ago by compn

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

damnit! ok, closing this bug. thanks for the link.

Note: See TracTickets for help on using tickets.