Opened 5 years ago

Closed 4 years ago

#2212 closed defect (fixed)

Resizing window does not maintain aspect ratio.

Reported by: ramma Owned by: beastd
Priority: normal Component: undetermined
Version: unspecified Severity: normal
Keywords: aspect ratio, resize Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:
Resizing the mplayer window has not maintained the aspect ratio since about Ubuntu 12.04. I have tested this on all versions from then up to 13.10 and the issue persists. Currently it is happening with mplayer 1.1-4.8, with unity 7.2.2.

How to reproduce:
Start video playback with default options.
Resize the window, aspect ratio will not be maintained.

Some searching revealed a few people saying this is actually a bug in the window manager. Is this actually the case?

Change History (6)

comment:1 Changed 5 years ago by ib

Are you talking about MPlayer or its GUI?

What SVN-revision (mplayer console output or About dialog in GUI) is your mplayer 1.1-4.8?

comment:2 Changed 4 years ago by ramma

I'm referring to Mplayer itself, I'm not using a GUI. I'm not sure how I would check the SVN-revision, but the version I'm using is what is in the official Ubuntu repos for 14.04.

comment:3 Changed 4 years ago by ib

To check the SVN-revision, open a terminal, type mplayer and see the first line. Copy it and paste it here.

comment:4 Changed 4 years ago by ramma

The first line says this "MPlayer 1.1-4.8 (C) 2000-2012 MPlayer Team"

It turns out installing mplayer2 as opposed to the mplayer package fixes this issue though.

comment:5 Changed 4 years ago by ib

Installing a recent version of MPlayer as opposed to one a few years old might help, too.

comment:6 Changed 4 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

To answer the original question: Yes, MPlayer relies on the window manager to respect the aspect hints for this feature to work.
Of course this assumes the -keepaspect is actually set.
In addition, current SVN MPlayer versions with -keepaspect will add black borders to fix aspect if the window manager does not respect the hints.
I think the latter justifies closing this as fixed, please reopen if you disagree.

Note: See TracTickets for help on using tickets.