Opened 5 years ago

Closed 4 years ago

#2223 closed defect (invalid)

DVB-T2 TS stream won't show video.

Reported by: jjarvela Owned by: beastd
Priority: normal Component: undetermined
Version: HEAD Severity: normal
Keywords: SVN-r37351-snapshot-4.9.1 Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:
DVB-T2 stream tuned by dvbv5-zap won't show video.

How to reproduce:

sudo dvbv5-zap -r -c dvb_channel.conf <channel>
reading channels from file 'dvb_channel.conf'
tuning to 642000000 Hz
video pid 310
  dvb_set_pesfilter 310
audio pid 850
  dvb_set_pesfilter 850
       (0x00)
Lock   (0x1f) C/N= 32.00dB
Lock   (0x1f) C/N= 32.00dB
DVR interface '/dev/dvb/adapter0/dvr0' can now be opened
Lock   (0x1f) C/N= 32.00dB


% sudo mplayer -v -vo fbdev2 /dev/dvb/adapter0/dvr0
MPlayer SVN-r37351-snapshot-4.9.1 (C) 2000-2014 MPlayer Team
Playing /dev/dvb/adapter0/dvr0.
get_path('sub/') -> '/home/joona/.mplayer/sub/'
[file] File size is 0 bytes
STREAM: [file] /dev/dvb/adapter0/dvr0
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
libavformat version 56.16.102 (internal)
Configuration: --enable-gpl --enable-postproc
LAVF_check: MPEG-TS (MPEG-2 Transport Stream)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /dev/dvb/adapter0/dvr0 ext: (null)
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 76, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -1,
Checking for MPEG-TS...
TRIED UP TO POSITION 13316, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
PROBING UP TO 0, PROG: 0
VIDEO MPEG2(pid=310) AUDIO A52(pid=850) NO SUBS (yet)!  PROGRAM N. 0
==> Found video stream: 0

ADDED VIDEO PID 310, type: 10000002 stream n. 0
==> Found audio stream: 0

ADDED AUDIO PID 850, type: 2000 stream n. 0
Opened TS demuxer, audio: 2000(pid 0), video: 10000002(pid 0)...POS=16780, PROBE=0

demux_ts, switched to audio pid 310, id: 0, sh: 0x7f577d0503f0

demux_ts, switched to audio pid 850, id: 0, sh: 0x7f577d050600
Searching for sequence header...



MPlayer version (C) ...
...

Patches should be submitted to the mplayer-dev-eng mailing list and not this bug tracker.

Change History (2)

comment:1 Changed 5 years ago by reimar

It looks like you include only the video and audio PID in the pesfilter.
This is not sufficient, you also need to include the PID that contains the description of the channels and codecs used, otherwise the result is not a valid TS stream.
You might get lucky and be able to play without that if you use -demuxer lavf, but that is not really a correct solution.
In general I'd suggest considering not enabling any pesfilter at all so that you can use MPlayer to select the desired program within the stream.

comment:2 Changed 4 years ago by beastd

  • Resolution set to invalid
  • Status changed from new to closed

From Reimar's analysis I conclude this is not an MPlayer bug, but the TS provided on /dev/dvb/adapter0/dvr0 contains insufficient information.

Thus I am closing this ticket. Feel free to re-open if you think think mplayer is the culprit.

Note: See TracTickets for help on using tickets.