Opened 15 years ago

Closed 12 years ago

#232 closed defect (fixed)

Screensaver Activation -> interrupted by signal 11

Reported by: ttomjones@… Owned by: beastd
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using the latest CVS (050117) released for Windows, I'am expiriencing the
problem, that the activation of the Windows screensaver interrupts MPlayer with
the following message:

mplayer.exe" -v -af volume=+20dB:sc "*apearently any video*"

MPlayer dev-CVS-050117-21:49 (C) 2000-2005 MPlayer Team
CPU: Intel Celeron 2/Pentium III Tualatin (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

CommandLine?: '-v' '-af' 'volume=+20dB:sc' '*apearently any video*'
init_freetype
*path_to_windows*/Fonts/arial.ttf doesn't look like a font description,
ignoring.
Cannot load font: *path_to_windows*/Fonts/arial.ttf
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Windows native timing
get_path('input.conf') -> '*path_to_mplayer*/input.conf'
Parsing input config file *path_to_mplayer*/input.conf
Input config file *path_to_mplayer*/input.conf parsed: 53 binds
get_path('*apearently any video*.conf') -

'*path_to_mplayer*/*apearently any video*.conf'

Playing *apearently any video*.
WINSOCK2 init: 0
[file] File size is 366839808 bytes
STREAM: [file] *apearently any video*
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
AVI file format detected.
list_end=0x3318
======= AVI Header =======
us/frame: 40000 (fps=25.000)
max bytes/sec: 0
padding: 0
MainAVIHeader.dwFlags: (272) HAS_INDEX IS_INTERLEAVED
frames total: 65522 initial: 0
streams: 3
Suggested BufferSize?: 0
Size: 640 x 528
==========================
list_end=0x10F4
==> Found video stream: 0

STREAM Header =====

Type: vids FCC: divx (78766964)
Flags: 0
Priority: 0 Language: 0
InitialFrames?: 0
Rate: 25000/1000 = 25.000
Start: 0 Len: 65522
Suggested BufferSize?: 46624
Quality 10000
Sample size: 0
==========================
found 'bih', 40 bytes of 40
======= VIDEO Format ======

biSize 40
biWidth 640
biHeight 528
biPlanes 1
biBitCount 24
biCompression 808802372='DX50'
biSizeImage 1013760

===========================
Regenerating keyframe table for MPEG4 video
list_end=0x217A
==> Found audio stream: 1

STREAM Header =====

Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames?: 1
Rate: 48000/1 = 48000.000
Start: 0 Len: 125802240
Suggested BufferSize?: 24000
Quality -1
Sample size: 1
==========================
found 'wf', 18 bytes of 18
======= WAVE Format =======
Format Tag: 8192 (0x2000)
Channels: 5
Samplerate: 48000
avg byte/sec: 48000
Block align: 1
bits/sample: 0
cbSize: 18
Unknown extra header dump: [0] [0] [0] [0] [0] [0] [35] [0] [4] [0] [0] [10] [0]

[1] [20] [3] [3f] [0]

===========================
list_end=0x320C
==> Found audio stream: 2

STREAM Header =====

Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames?: 1
Rate: 48000/1152 = 41.667
Start: 0 Len: 109203
Suggested BufferSize?: 480
Quality -1
Sample size: 0
==========================
found 'wf', 30 bytes of 18
======= WAVE Format =======
Format Tag: 85 (0x55)
Channels: 2
Samplerate: 48000
avg byte/sec: 18007
Block align: 1152
bits/sample: 0
cbSize: 12
mp3.wID=1
mp3.fdwFlags=0x2
mp3.nBlockSize=432
mp3.nFramesPerBlock=1
mp3.nCodecDelay=0
===========================
list_end=0x3318
AVI: dmlh found (size=248) (total_frames=65522)
list_end=0x333C
hdr=Software size=15
Software : Nandub v1.0rc2
list_end=0x15A2E0B6
Found movie at 0x380C - 0x15A2E0B6
Reading INDEX block, 240236 chunks for 65522 frames (fpos=15A2E0BE)
AVI index offset: 0x3808 (movi=0x380C idx0=0x4 idx1=0x5DCC)
Auto-selected AVI audio ID = 1
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:1)
AVI video size=188028435 (65522) audio size=125802240 (125802240)
VIDEO: [DX50] 640x528 24bpp 25.000 fps 573.9 kbps (70.1 kbyte/s)
[V] filefmt:3 fourcc:0x30355844 size:640x528 fps:25.00 ftime:=0.0400
Clip info:

Software: Nandub v1.0rc2

get_path('sub/') -> '*path_to_mplayer*/sub/'

get_path('default.sub') -> '*path_to_mplayer*/default.sub'
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
No accelerated IMDCT transform found
AC3: 5.1 (3f+2r+lfe) 48000 Hz 384.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0xA
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x9), ratio: 48000->192000 (384.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
<vo_directx><INFO>checking primary surface
<vo_directx><FORMAT PRIMARY>14 BGR32 supported
<vo_directx><INFO>testing supported overlay pixelformats
<vo_directx><FORMAT OVERLAY>0 YV12 supported
<vo_directx><FORMAT OVERLAY>1 I420 not supported
<vo_directx><FORMAT OVERLAY>2 IYUV supported
<vo_directx><FORMAT OVERLAY>3 YVU9 supported
<vo_directx><FORMAT OVERLAY>4 YUY2 supported
<vo_directx><FORMAT OVERLAY>5 UYVY supported
<vo_directx><FORMAT OVERLAY>6 BGR8 not supported
<vo_directx><FORMAT OVERLAY>7 RGB15 supported
<vo_directx><FORMAT OVERLAY>8 BGR15 supported
<vo_directx><FORMAT OVERLAY>9 RGB16 supported
<vo_directx><FORMAT OVERLAY>10 BGR16 supported
<vo_directx><FORMAT OVERLAY>11 RGB24 not supported
<vo_directx><FORMAT OVERLAY>12 BGR24 not supported
<vo_directx><FORMAT OVERLAY>13 RGB32 supported
<vo_directx><FORMAT OVERLAY>14 BGR32 supported
<vo_directx><INFO>Your card supports 11 of 15 overlayformats
<vo_directx><INFO>hardware supports overlay
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
[libaf] Adding filter volume
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little-endian 16-bit signed int
AF_pre: 48000Hz 2ch little-endian 16-bit signed int
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 VIA Audio (WAVE)
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:48000Hz Channels:2 Format:s16le
ao_dsound: Buffersize:192000 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 48000Hz 2ch little-endian 16-bit signed int (2 bps)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
[ffmpeg] aspect_ratio: 1.212121
VDec: vo config request - 640 x 528 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.21:1 - prescaling to correct movie aspect.
VO Config (640x528->640x528,flags=0,'MPlayer',0x32315659)
VO: [directx] 640x528 => 640x528 Planar YV12
VO: Description: Directx DDraw YUV/RGB/BGR renderer
VO: Author: Sascha Sommer <saschasommer@…>
<vo_directx><INFO>overlay with format YV12 created
* [vo] Allocating (slices) mp_image_t, 640x528x12bpp YUV planar, 506880 bytes
XXX initial v_pts=0.000 a_pos=24000 (0.500)
* [vo] Allocating (slices) mp_image_t, 640x528x12bpp YUV planar, 506880 bytes
Unicode font: 1185 glyphs.
<vo_directx><INFO>killing screensaver

MPlayer interrupted by signal 11 in module: decode_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Uninit audio filters...
[libaf] Removing filter volume
uninit audio: liba52
uninit video: ffmpeg
WINSOCK2 uninit
ao_dsound: DirectSound? uninitialized

OS: Windows 2003 Server (incl. all available fixes)
Grapic Card & Driver: ATI Radeon Mobility-P AGP 4x v6.13.10.6006
DirectX: 9.0c 4.09.0000.0904

It seems that MPlayer detects the activation of the screensaver, attempts to
kill it and that fails.
It doesn't matter if the video is played in fullscreen or in a window.

I hope this is not specific to my hardware. Anyway if you need to know more
drop me a message.

Greetings,
Marcus Hoffmann

Attachments (1)

vo_dx_screensave.diff (512 bytes) - added by reimar 15 years ago.
missing break…

Download all attachments as: .zip

Change History (7)

Changed 15 years ago by reimar

missing break...

comment:1 Changed 15 years ago by reimar

It seems there is a break missing - I doubt it will make any difference but
please try it anyway.

comment:2 Changed 15 years ago by ttomjones@…

I tried but there is no difference.

Just to be precise, I'm now using dev-CVS-050213-14:08-3.2.3, with
'./configure --with-codecsdir=/path/to/codecs --enable-debug' followed by a
simple
'make'

AFAIKS there is no action taken when the screensaver is activated.
I consider that the source of the problem.

Marcus

comment:3 Changed 15 years ago by ttomjones@…

I ran a gdb and traced the bug to the location depicted below.
However I suspect that is not the real source of the error.

I imagine something like:
coping from buffer to DirectX, w/o screensaver having destroyed the DX-graphic
context: works perfectly
and coping from buffer to DirectX, w/ screensaver having destroyed the DX-
graphic context: invalidates the corresponding DX-buffer / selector.

E:\mplayer\main>gdb --args mplayer.exe /a.avi
GNU gdb 5.2.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i686-pc-mingw32"...
(gdb) run
Starting program: E:\mplayer\main/mplayer.exe /a.avi

Program received signal SIGSEGV, Segmentation fault.
0x004415b6 in fast_memcpy_MMX2 (to=0x0, from=0x4a645c0, len=0)

at aclib_template.c:320

320 asm volatile (
(gdb) list
315 : "%"REG_a, "%ebx"
316 );
317
318 for(; i>0; i--)
319 {
320 asm volatile (
321 #ifndef HAVE_MMX1
322 PREFETCH" 320(%0)\n"
323 #endif
324 "movq (%0), %%mm0\n"
(gdb) quit
The program is running. Exit anyway? (y or n) y

Marcus

comment:4 Changed 14 years ago by ttomjones@…

Please don't think I want to urge the issue but I encounterd quite the same
problem with an other computer.
This time not only the mplayer process gets killed, the whole machine is stoped
(blue screen in a display driver DLL).

First I could not link the blue screen directly to the mplayer program, until I
turned off the screen saver for some reason.
Suddenly the BSODs were gone.

Yes, the BSOD is in fact a problem of a buggy driver, but since it's avoidable
it would be nice to have the screensaver disabled while watching a movie with
mplayer.

Yours Marcus Hoffmann

PS: the graphic card in this machine is a Matrox Millennium G200 AGP w/ the
driver version 5.93.9.0 provided by Windows Update September the 14th of 2004.

comment:5 Changed 13 years ago by diego@…

  • Owner changed from alex@… to beastd

comment:6 Changed 12 years ago by zuxy.meng@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r24861.

Note: See TracTickets for help on using tickets.