Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2331 closed defect (fixed)

Video plays fast after first loop using -loop

Reported by: redxii Owned by: beastd
Priority: normal Component: undetermined
Version: unspecified Severity: minor
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

When using -loop, videos play at normal speed but after the first play it begins to play at a really accelerated pace.

mplayer big-buck-bunny_trailer.webm -loop 2

Logs/sample attached.

Attachments (2)

loop.log (26.6 KB) - added by redxii 3 months ago.
Command-line output
big-buck-bunny_trailer.webm (2.1 MB) - added by redxii 3 months ago.

Change History (6)

Changed 3 months ago by redxii

Command-line output

Changed 3 months ago by redxii

comment:1 Changed 3 months ago by beastd

  • Status changed from new to open

Reproducible here.

comment:2 Changed 3 months ago by beastd

  • Cc reimar added

This is a regression since SVN r37936 .

The bug only occurs with

mplayer big-buck-bunny_trailer.webm -loop 2

but not with

mplayer -loop 2 big-buck-bunny_trailer.webm

comment:3 Changed 3 months ago by reimar

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by r37953

comment:4 Changed 3 months ago by beastd

Re-tested with r37953 and it works again here.

Note: See TracTickets for help on using tickets.