Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#361 closed defect (fixed)

can't play video-file correctly

Reported by: tomasgroth@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've gotten my hands on a video file, but i'm not entirely sure what format it
is... But the problem is: mplayer can't play it, while xine can.
Acording to xine the video-codec is VP50, and xine plays it flawlessly. Mplayer
doesn't detect the video, and has major problems playing the AAC sound.
my mplayer version: MPlayer dev-CVS-050822-20:59-3.4.3
The file "deadweight" has been uploaded to incoming

Change History (5)

comment:1 Changed 14 years ago by r_togni@…

  • Owner changed from moritz@… to r_togni@…

The file is an NSV file with one more packeting layer (ultravox), and this
variant is not currently supported by mplayer (so nsv demuxer detection fails).

Since the file contains aac data, it's recognized as raw aac files, but since it
also contains video and nsv data, faad spits out a lot of errors.

comment:2 Changed 13 years ago by reimar

ultravox format is now supported, but at the streaming layer. So the following
should work for playing (with latest CVS):
Put it up on a web server and then play it via unsv://host/file.uvox
Please tell us if it works.
P.S. you can use -dumpstream to get rid of the ultravox data.

comment:3 Changed 13 years ago by tomasgroth@…

It works now! thx!

comment:4 Changed 13 years ago by tomasgroth@…

hmm, maybe i was a bit too fast... It does play now, but it the A/V is out of
sync by about 0.5 second, and seeking isn't possible.
I'm using MPlayer dev-CVS-051002-19:30-4.0.2
I'd tryed to get a newer cvs-version, but it seems to be broken ATM

comment:5 Changed 12 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

A-V sync seems fine to me, and half-working seeking is available via -demuxer
lavf. But since the format was never intended for seeking, non-working seeking
is not really a bug. And you can always remux into some format that supports
seeking, e.g. into AVI with mencoder.

Note: See TracTickets for help on using tickets.