Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#433 closed defect (wontfix)

streaming hangs, same content plays after download

Reported by: gamik@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

This stream makes mplayer hang:
http://kino.search.ch/movie/trailer/8230/trailerwidehigh1.rm

MPlayer SuSE Linux 9.3 (i686)-Packman-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Intel (Family: 8, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
...

Resolving kino.search.ch for AF_INET...
Connecting to server kino.search.ch[212.243.222.231]:80 ...
Cache size set to 320 KBytes
Connected to server: kino.search.ch
Cache fill: 15.00% (49152 bytes) REAL file format detected.
Stream description: audio/x-pn-multirate-realaudio logical stream
Stream mimetype: logical-audio/x-pn-multirate-realaudio
Stream description: video/x-pn-multirate-realvideo logical stream
Stream mimetype: logical-video/x-pn-multirate-realvideo
Stream description: fileinfo
Stream mimetype: logical-fileinfo
Stream description: Audio Stream
Stream mimetype: audio/x-pn-multirate-realaudio
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Audio Stream
Stream mimetype: audio/x-pn-multirate-realaudio
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
Stream description: Audio Stream
Stream mimetype: audio/x-pn-multirate-realaudio
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Stream description: Video Stream
Stream mimetype: video/x-pn-multirate-realvideo
Resolving kino.search.ch for AF_INET...
Connecting to server kino.search.ch[212.243.222.231]:80 ...

When first downloading the stream with wget and then playing,
it works without problems:

wget http://kino.search.ch/movie/trailer/8230/trailerwidehigh1.rm
mplayer trailerwidehigh1.rm

Change History (3)

comment:1 Changed 14 years ago by r_togni@…

  • Resolution set to wontfix
  • Status changed from new to closed

This is not a RealMedia? stream, but a file downloadable over http.

The file is a multirate file (it contains the same audio/video content encoded
with different bitrates), and those files are not interleaved, so you can't
easily play them over the network (a normal file is like AVVVAVVAAVVVVAVVVAV, so
you just read it sequentially and you get A and V blocks; a non-interleaved file
is like AAAA...AAAAAAAVVVVVVVVVV....VVVVVVVVVVVV, so you need to do many seek
forward and backward to get A or V data when you need them).

Moreover MPlayer uses the index to know where every A or V block is in the file,
and index is at the end in rm files, so you need to have the complete file to
play it back. This could be solved by creating a smarter demuxer, but the
continous seeking is unavoidable (unless you buffer all A or all V data in advance).

Note: I resolved this bug as WONTFIX because i can't find a better resolution;
WORKSFORME would be also ok since MPlayer is supposed to behave this way. The
bugreport is not INVALID (the file can't be playerd over the network), but i'd
say it's not a bug

comment:2 Changed 14 years ago by gamik@…

(In reply to comment #1)

ok, I see. Some more comments, though:

This is not a RealMedia? stream, but a file downloadable over http.

other than looking at the download speed, how can I see that this file is not
streamed by the http server? Is this possible at all?

is like AAAA...AAAAAAAVVVVVVVVVV....VVVVVVVVVVVV, so you need to do many seek
forward and backward to get A or V data when you need them).

How did you figure out that it isn't interleaved? Variable bitrate streams could
in general be interleaved, right? Is this property specific to that particular
format?

and index is at the end in rm files, so you need to have the complete file to

...

bugreport is not INVALID (the file can't be playerd over the network), but i'd
say it's not a bug

If I use an URL instead of a filename with mplayer, does that mean that mplayer
_always_ treats this media as being streamed? (not documented i the manpage).
Shouldn't mplayer detect that it needs the whole file and download it before
playing?

comment:3 Changed 14 years ago by reimar

Try again with latest CVS. At least with -novideo it should work fine.

Note: See TracTickets for help on using tickets.