Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#442 closed defect (fixed)

Tivo .ty streams cause 'signal 11 in module: init_audio_codec'

Reported by: joe@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The latest version of mplayer doesn't appear to play Tivo .ty streams any more.
(This is on FreeBSD 6-stable).

What I get is:

genius% mplayer 3587317.ty
MPlayer 1.0pre7try2-3.4.4 (C) 2000-2005 MPlayer Team
CPU: Intel (Family: 6, Stepping: 6)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

73 audio & 180 video codecs
Playing 3587317.ty.
TiVo? file format detected.
VIDEO: MPEG2 544x576 (aspect 2) 25.000 fps 5800.0 kbps (725.0 kbyte/s)
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder

MPlayer interrupted by signal 11 in module: init_audio_codec

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

However it does play fine on the same platform using an older version of mplayer:

genius% mplayer 3587317.ty
MPlayer 1.0pre6-3.4.2 (C) 2000-2004 MPlayer Team
CPU: Intel (Family: 6, Stepping: 6)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

73 audio & 180 video codecs
Playing 3587317.ty.
TiVo? file format detected.
VIDEO: MPEG2 544x576 (aspect 2) 25.000 fps 5800.0 kbps (725.0 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 32000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->128000 (192.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
vo: X11 running at 1920x1200 with depth 16 and 16 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 544 x 576 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 32000 hz, little endian signed int
AF_pre: 32000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 32000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 544 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 544x576 => 768x576 Planar YV12
New_Face failed. Maybe the font path is wrong. 2 ??% ??% ??,?% 0 0
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A:1422.0 V:1421.7 A-V: 0.222 ct: -0.036 16/ 16 31% 31% 5.7% 0 0
Exiting... (Quit)

Change History (3)

comment:1 Changed 14 years ago by joe@…

  • bug_file_loc set to http://www.josef-k.net/misc/test.ty

I've added a test .ty file to my website (http://www.josef-k.net/misc/test.ty) as an
example.

comment:2 Changed 14 years ago by dominik@…

Works for me on Linux with MPlayer dev-Fedora-GS-CVS-060126-21:48-4.0.2

Retry with latest CVS. If it still occurs, please provide a gdb backtrace of
mplayer compiled with debuginfo as outlined in bugreports.html.

comment:3 Changed 14 years ago by joe@…

  • Resolution set to fixed
  • Status changed from new to closed

Yes :). Looks like the cvs head version works! Roll on another release :).

Note: See TracTickets for help on using tickets.