Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#472 closed defect (fixed)

Encoding to DVD MPEG2 Breaking after 20060208

Reported by: aksomitis@… Owned by: diego@…
Priority: important Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm having some strange behaviour with Newer Versions of mencoder. I'm seeing 3
different behaviours, and I am unable to determine for sure if they are related.

So, as in the Bug Reporting Documents, I checked out a Ton of different Dates

of CVS with the -D option, and created a number of logfiles which have some or
none of the Behaviours I'm seeing. The logfiles are from my tovob.pl lazy-man's
automation. Every Command is printed out the the logfile before executing it.
The 3 behaviour's I'm seeing are:
1) Large volumes of the following in the 2nd pass output:
ERROR: SCR: 124324902335, APTS: 124323840000, DELTA=-0.012 secs, COMPENSATE=276,
BR: 24000, lens: 2016/2016, frames: 3

2) Without a preconv encoding to correct Framerate, mplayer is unable to even to
a -dumpvideo on the file it created, it bails 1/2 through with message:
demux: File doesn't contain the selected audio or video stream

3) vrc_maxrate and 2-pass encoding for a specific size doesn't seem to always
work, especially without a FPS pre-conversion.

I would like to help however I can. I have all my logfiles ready to upload to
your server, but I can not seem to see the incoming Directory ??
To that end, I have apache running locally (albeit with a Dynamic IP). This URL
should be good for a bit:
http://64.110.194.57:4444/mplayer

If timezone matters to the -D option, I am in GMT-6, no daylite savings.
Pls advise If I am missing Any info, or if their is any tests you would like me
to run !!

NOTE: Problem does not appear to be different between 32 and 64 bit compiles (
used old 32-bit machine and 32 bit chroot jail, results identical).

Eric Aksomitis
aksomitis@…

Change History (1)

comment:1 Changed 13 years ago by aksomitis@…

  • Resolution set to fixed
  • Status changed from new to closed

Wow, What are the odds. Between Me starting my Regression testing on the 18th,
and the 26th, all 3 behaviours seem fixed with Current CVS.

However, just in case anyone is interested in seeing the logs, I'll leave them
up.....

Thanx !

Note: See TracTickets for help on using tickets.