Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#568 closed defect (invalid)

Cannot play RTSP stream from QTSS server on MacOS

Reported by: andrew@… Owned by: r_togni@…
Priority: important Component: streaming
Version: 1.0pre8 Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mplayer incorrectly decides that an RTSP stream from a QTSS server is invalid
and falls back to HTTP (which fails).

Code in libmpdemux/realrtsp/rtsp_session.c requires that the server be
"Real*" or "Helix*" or send a RealChallenge1 header

QTSS sends

RTSP/1.0 200 OK
Server: QTSS/5.5.3 (Build/489.0.4; Platform/MacOSX; Release/Update?; )
Cseq: 1
Public: DESCRIBE, SETUP, TEARDOWN, PLAY, PAUSE, OPTIONS, ANNOUNCE, RECORD

and reportedly works with other media players (Quicktime, VLC)

Change History (4)

comment:1 Changed 13 years ago by andrew@…

An attempt to add QTSS as an allowable server type fails with
a SIGSEV since the "real" code requires the proprietary RealChallenge1
string and crashes when it is absent.

It's not clear to me whether mplayer supports generic RTSP as per
RFC 2326 etc.

comment:2 Changed 13 years ago by r_togni@…

  • Resolution set to invalid
  • Status changed from new to closed

Realrtsp only handles Realnetworks streams. MPlayer also has code for mpeg over
rtsp.

For generic rtsp support you must install live555 library.

comment:3 Changed 13 years ago by andrew@…

thanks for quick response!

I have rebuilt with latest live555 code and get the same thing -
mplayer says "not a Real server", falls back to HTTP and fails

comment:4 Changed 13 years ago by andrew@…

looks like I should have done "make distclean" before recompiling .. plays now,
but at wrong speed

Note: See TracTickets for help on using tickets.