Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#680 closed defect (invalid)

Build dies in vo_fbdev.o in today's SVN

Reported by: ronis@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm running slackware-11.0, frg-gnome-current, gcc-4.1.1, and have just
upgraded the kernel from 2.6.18.3 to 2.6.19. I've been following mplayer for
years.

After doing an svn update for mplayer,
reconfiguring, (configure --enable-gui, CFLAGS/CXXFLAGS unset) make
clean, make. The build dies as indicated below. Please CC me on any
reply as I don't subscribe to this list.

David

make -C libvo libvo.a
make[1]: Entering directory `/home/ronis/Project/notar/mplayer/libvo'
/usr/bin/gcc -I../osdep -I../libavutil -I. -I..
-Wdeclaration-after-statement -O4 -march=pentium4 -mtune=pentium4 -pipe
-ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I/usr/X11/include
-I/usr/include/ -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT
-I/opt/kde/include/artsc -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include -I/usr/include/dvdnav
-I/usr/include/freetype2 -I/usr/include -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -c -o vo_fbdev.o vo_fbdev.c
In file included from /usr/include/linux/bitops.h:9,

from /usr/include/linux/thread_info.h:20,
from /usr/include/linux/preempt.h:9,
from /usr/include/linux/spinlock.h:49,
from /usr/include/linux/module.h:10,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/asm/bitops.h:244: error: expected '=', ',', ';', 'asm' or
'attribute' before 'int'
In file included from /usr/include/linux/spinlock.h:56,

from /usr/include/linux/module.h:10,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/asm/system.h:342: error: expected declaration specifiers or
'...' before 'u8'
/usr/include/asm/system.h:342: error: expected declaration specifiers or
'...' before 'u8'
/usr/include/asm/system.h:343: error: expected declaration specifiers or
'...' before 'u16'
/usr/include/asm/system.h:343: error: expected declaration specifiers or
'...' before 'u16'
/usr/include/asm/system.h:344: error: expected declaration specifiers or
'...' before 'u32'
/usr/include/asm/system.h:344: error: expected declaration specifiers or
'...' before 'u32'
/usr/include/asm/system.h: In function 'cmpxchg_386':
/usr/include/asm/system.h:351: error: too many arguments to function
'cmpxchg_386_u8'
/usr/include/asm/system.h:353: error: too many arguments to function
'cmpxchg_386_u16'
/usr/include/asm/system.h:355: error: too many arguments to function
'cmpxchg_386_u32'
In file included from /usr/include/linux/cpumask.h:86,

from /usr/include/asm/processor.h:22,
from /usr/include/asm/atomic.h:5,
from /usr/include/linux/spinlock.h:273,
from /usr/include/linux/module.h:10,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/linux/bitmap.h: In function 'bitmap_zero':
/usr/include/linux/bitmap.h:134: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h:134: error: (Each undeclared identifier is
reported only once
/usr/include/linux/bitmap.h:134: error: for each function it appears
in.)
/usr/include/linux/bitmap.h: In function 'bitmap_fill':
/usr/include/linux/bitmap.h:149: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_copy':
/usr/include/linux/bitmap.h:155: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_and':
/usr/include/linux/bitmap.h:166: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_or':
/usr/include/linux/bitmap.h:175: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_xor':
/usr/include/linux/bitmap.h:184: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_andnot':
/usr/include/linux/bitmap.h:193: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_complement':
/usr/include/linux/bitmap.h:202: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_equal':
/usr/include/linux/bitmap.h:211: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_intersects':
/usr/include/linux/bitmap.h:220: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_subset':
/usr/include/linux/bitmap.h:229: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_empty':
/usr/include/linux/bitmap.h:237: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_full':
/usr/include/linux/bitmap.h:245: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_weight':
/usr/include/linux/bitmap.h:253: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_shift_right':
/usr/include/linux/bitmap.h:261: error: 'BITS_PER_LONG' undeclared
(first use in this function)
/usr/include/linux/bitmap.h: In function 'bitmap_shift_left':
/usr/include/linux/bitmap.h:270: error: 'BITS_PER_LONG' undeclared
(first use in this function)
In file included from /usr/include/asm/processor.h:22,

from /usr/include/asm/atomic.h:5,
from /usr/include/linux/spinlock.h:273,
from /usr/include/linux/module.h:10,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/linux/cpumask.h: At top level:
/usr/include/linux/cpumask.h:88: error: expected
specifier-qualifier-list before 'DECLARE_BITMAP'
/usr/include/linux/cpumask.h: In function 'cpu_set':
/usr/include/linux/cpumask.h:94: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpu_clear':
/usr/include/linux/cpumask.h:100: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_setall':
/usr/include/linux/cpumask.h:106: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_clear':
/usr/include/linux/cpumask.h:112: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpu_test_and_set':
/usr/include/linux/cpumask.h:121: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_and':
/usr/include/linux/cpumask.h:128: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:128: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:128: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_or':
/usr/include/linux/cpumask.h:135: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:135: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:135: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_xor':
/usr/include/linux/cpumask.h:142: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:142: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:142: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_andnot':
/usr/include/linux/cpumask.h:150: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:150: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:150: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_complement':
/usr/include/linux/cpumask.h:157: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:157: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_equal':
/usr/include/linux/cpumask.h:164: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:164: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_intersects':
/usr/include/linux/cpumask.h:171: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:171: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_subset':
/usr/include/linux/cpumask.h:178: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:178: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_empty':
/usr/include/linux/cpumask.h:184: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_full':
/usr/include/linux/cpumask.h:190: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_weight':
/usr/include/linux/cpumask.h:196: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpus_shift_right':
/usr/include/linux/cpumask.h:204: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:204: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_shift_left':
/usr/include/linux/cpumask.h:212: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:212: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpumask_scnprintf':
/usr/include/linux/cpumask.h:273: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpumask_parse_user':
/usr/include/linux/cpumask.h:281: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpulist_scnprintf':
/usr/include/linux/cpumask.h:289: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpulist_parse':
/usr/include/linux/cpumask.h:295: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function 'cpu_remap':
/usr/include/linux/cpumask.h:303: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:303: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h: In function '
cpus_remap':
/usr/include/linux/cpumask.h:311: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:311: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:311: error: 'cpumask_t' has no member named
'bits'
/usr/include/linux/cpumask.h:311: error: 'cpumask_t' has no member named
'bits'
In file included from /usr/include/asm/atomic.h:5,

from /usr/include/linux/spinlock.h:273,
from /usr/include/linux/module.h:10,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/asm/processor.h: At top level:
/usr/include/asm/processor.h:80: error: 'CONFIG_X86_L1_CACHE_SHIFT'
undeclared here (not in a function)
/usr/include/asm/processor.h:80: error: requested alignment is not a
constant
In file included from /usr/include/linux/module.h:11,

from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/linux/list.h:902:2: warning: #warning "don't include kernel
headers in userspace"
In file included from /usr/include/asm/local.h:4,

from /usr/include/linux/module.h:20,
from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/linux/percpu.h:65: error: expected declaration specifiers
or '...' before 'gfp_t'
/usr/include/linux/percpu.h:71: error: expected declaration specifiers
or '...' before 'gfp_t'
/usr/include/linux/percpu.h:77: error: expected '=', ',', ';', 'asm' or
'attribute' before 'void'
In file included from /usr/include/linux/module.h:22,

from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/asm/module.h:60:2: error: #error unknown processor family
In file included from /usr/local/include/linux/i2c.h:34,

from /usr/include/linux/fb.h:5,
from vo_fbdev.c:21:

/usr/include/linux/module.h:49: error: field 'attr' has incomplete type
/usr/include/linux/module.h:60: error: field 'kobj' has incomplete type
In file included from /usr/include/linux/fb.h:5,

from vo_fbdev.c:21:

/usr/local/include/linux/i2c.h:71: error: array type has incomplete
element type
/usr/local/include/linux/i2c.h:87: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_xfer'
/usr/local/include/linux/i2c.h:95: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_quick'
/usr/local/include/linux/i2c.h:96: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_read_byte'
/usr/local/include/linux/i2c.h:97: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_byte'
/usr/local/include/linux/i2c.h:98: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_read_byte_data'
/usr/local/include/linux/i2c.h:99: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_byte_data'
/usr/local/include/linux/i2c.h:101: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_read_word_data'
/usr/local/include/linux/i2c.h:102: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_word_data'
/usr/local/include/linux/i2c.h:104: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_process_call'
/usr/local/include/linux/i2c.h:107: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_read_block_data'
/usr/local/include/linux/i2c.h:109: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_block_data'
/usr/local/include/linux/i2c.h:112: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_read_i2c_block_data'
/usr/local/include/linux/i2c.h:114: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_smbus_write_i2c_block_data'
/usr/local/include/linux/i2c.h:190: error: array type has incomplete
element type
/usr/local/include/linux/i2c.h:192: error: expected declaration
specifiers or '...' before 'u16'
/usr/local/include/linux/i2c.h:194: error: expected declaration
specifiers or '...' before 'u8'
/usr/local/include/linux/i2c.h:204: error: expected
specifier-qualifier-list before 'u32'
/usr/local/include/linux/i2c.h:229: error: field 'bus' has incomplete
type
/usr/local/include/linux/i2c.h:230: error: field 'list' has incomplete
type
/usr/local/include/linux/i2c.h:347: error: expected '=', ',', ';', 'asm'
or 'attribute' before 'i2c_get_functionality'
/usr/local/include/linux/i2c.h:350: error: expected declaration
specifiers or '...' before 'u32'
/usr/local/include/linux/i2c.h: In function 'i2c_delay':
/usr/local/include/linux/i2c.h:570: error: 'TASK_INTERRUPTIBLE'
undeclared (first use in this function)
make[1]: * [vo_fbdev.o] Error 1
make[1]: Leaving directory `/home/ronis/Project/notar/mplayer/libvo'
make:
* [libvo/libvo.a] Error 2

Change History (3)

comment:1 Changed 12 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Your installed linux kernel headers are broken, esp. this:

from /usr/local/include/linux/i2c.h:34,
from /usr/include/linux/fb.h:5,

Combining headers from /usr/include and /usr/local/include almost certainly is
wrong.

comment:2 Changed 12 years ago by ronis@…

Thanks for the reply. I agree with your conculsion; What's amazing is that
/usr/local/include/linux has been on this box since the beginning of 2004. I
removed the subdirectory and, sure enough, mplayer compiles.

comment:3 Changed 12 years ago by reimar

/usr/local/include/linux has been on this box since the beginning of 2004.

Well, I guess that was no problem while the headers in /usr/include/linux were
from 2004, too, but I'd guess they were updated somewhen. Linux headers from two
years apart are unlikely to work well together ;-)

Note: See TracTickets for help on using tickets.