Opened 12 years ago

Closed 12 years ago

#759 closed defect (wontfix)

No stream found in MOV container

Reported by: palos@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

"No stream found" error occurs when I try to play some Quicktime animations. These files are on an original CD and can be played by Quicktime 6 under Windows so they do not sem to be corrupted. The same problem with both 1.0rc1 and 2007-02-17 versions of MPlayer.
'mplayer file.mov -msglevel all=9'
gives (only the important part is copied here):

[file] File size is 379942 bytes
STREAM: [file] file.mov
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
s->pos=0 newpos=0 new_bufpos=0 buflen=0
DEMUXER: freeing demuxer at 0x8eb19c0
Checking for YUV4MPEG2
DEMUXER: freeing demuxer at 0x8eb19c0
ASF_check: not ASF guid!
DEMUXER: freeing demuxer at 0x8eb19c0
Checking for NuppelVideo?
DEMUXER: freeing demuxer at 0x8eb19c0
Checking for REAL
DEMUXER: freeing demuxer at 0x8eb19c0
Checking for SMJPEG
DEMUXER: freeing demuxer at 0x8eb19c0
SUB: opened iconv descriptor.
[mkv] no head found
DEMUXER: freeing demuxer at 0x8eb19c0
DEMUXER: freeing demuxer at 0x8eb19c0
DEMUXER: freeing demuxer at 0x8eb19c0
SUB: opened iconv descriptor.
Ogg demuxer : Bad page sync
DEMUXER: freeing demuxer at 0x8eb19c0
SUB: closed iconv descriptor.
Searching demuxer type for filename file.mov ext: .mov
Trying demuxer 7 based on filename extension
s->pos=1000 newpos=0 new_bufpos=0 buflen=0
Checking for MOV
MOV: Movie header found!
MOV: Movie header: start: 8 end: 300
MOV: free space (len: 8)
MOV: 'WIDE' chunk found!
MOV: Movie DATA found!
MOV: Movie data: start: 310 end: 310
Quicktime/MOV file format detected.
mov_read_header!
lschunks dhvm 100
MOV: Movie header (100 bytes): tscale=600 dur=48200
lschunks kart 579


MOV: Track #0:
lschunks dhkt 84
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=48200 lay=1 vol=256
lschunks stde 28
MOV: Edit atom!
lschunks tsle 20
MOV: Edit list table (1 entries) (ver:0,flags:0)
MOV: entry#0: duration: 48200 start time: 0 speed: 1.0x
lschunks aidm 443
MOV: Media stream!
lschunks dhdm 24
MOV: Media header!
lschunks rldh 44
MOV: Handler header: mhlr/flsh (appl) Flash Media Handler
lschunks fnim 351
MOV: Media info!
lschunks dhmg 24
MOV: Generic header!
lschunks rldh 49
MOV: Handler header: dhlr/alis (appl) Apple Alias Data Handler
lschunks fnid 28
MOV: unknown chunk: dinf 28
lschunks lbts 136
MOV: Sample info!
lschunks dsts 36
MOV: Description list! (cnt:1)
MOV: desc #0: (12 bytes)
lschunks stts 16
MOV: Sample duration table! (1 blocks)
lschunks csts 20
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
lschunks zsts 12
MOV: Sample size table! (entries=1 ss=378366) (ver:0,flags:0)
lschunks octs 12
MOV: Chunk offset table! (1 chunks)
lschunks edoc 74
MOV track #0: 1 chunks, 0 samples
pts=48200 scale=600 time=80.333
Sample 0: pts= 0 off=0x00000328 size=378366
EL#0: pts=0 1st_sample=0 frames=1 (80.333s) pts_offs=0
Generic track - not completely understood! (id: 0)


lschunks atdu 57
mov: user data record found
Quicktime Clip Info:
udta_id: yalp (len: 9)
udta_id: gulp (len: 23)
udta_id: FllA (len: 9)
MOV: longest streams: A: #-1 (0 samples) V: #-1 (0 samples)
No stream found.

* uninit(0x248)
DEMUXER: freeing demuxer at 0x8eb19c0

Attachments (1)

file.mov (371.0 KB) - added by palos@… 12 years ago.
the file.mov file from report

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by palos@…

the file.mov file from report

comment:1 Changed 12 years ago by palos@…

comment:2 Changed 12 years ago by compn

quicktime 7.1 in mac osx 'plays' the audio, but i hear nothing
and see no video...

comment:3 Changed 12 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

This file does not contain any "tracks".
The reason for this is simple: This is a flash file wrapped in a horrible ugly way into a move file.
If you just delete the first 0x328 bytes (resulting file will start with "FWS") it should play fine in flash player or even gnash (sound will work in MPlayer, too).
Support for this IMO is outside of what MPlayer is there for.

Note: See TracTickets for help on using tickets.