Opened 12 years ago

Closed 12 years ago

#785 closed defect (duplicate)

Can compile with --enable-debug

Reported by: corrado91@… Owned by: diego@…
Priority: important Component: build system
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When compiling with --enable-debug I get the following error:
In file included from msmpeg4.c:1938:
wmv2.c:842: warning: missing initializer
wmv2.c:842: warning: (near initialization for `wmv2_decoder.next')
msmpeg4.c: In function `msmpeg4_pred_dc':
msmpeg4.c:663: error: can't find a register in class GENERAL_REGS' while reloading asm'
make[1]: * [msmpeg4.o] Error 1
make[1]: Leaving directory `/home/tbretz/MPlayer-1.0rc1/libavcodec'
make:
* [libavcodec/libavcodec.a] Error 2

(I'm using Suse 9.2 with gcc 3.3.4)

BTW: Compared to a few compiler warnings at pre6a I get hundreds now...

Since rc7try2 (excluded) all mplayer releases crash directly after startup. Coz I can't do a backtrace I cannot send aproper bug report for this.

Change History (3)

comment:1 Changed 12 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of bug 604 *

comment:2 Changed 12 years ago by diego@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopen to mark as duplicate of another bug.

comment:3 Changed 12 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from reopened to closed

* This bug has been marked as a duplicate of bug 87 *

Note: See TracTickets for help on using tickets.