Opened 12 years ago

Closed 8 years ago

#797 closed enhancement (wontfix)

add support for reading from .isz (iso-like image)

Reported by: compn Owned by: reimar
Priority: if idle Component: demuxer
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Change History (7)

comment:1 Changed 12 years ago by reimar

Support for this does not belong into MPlayer (and to work properly would mean also implemention ISO9660 and UDF and whatever) but instead into file system drivers, e.g. fuse - more specifically mountlo (http://sourceforge.net/project/showfiles.php?group_id=121684&package_id=150116) looks like a good place to add support for it.
Unless of course you mean as part of VCD support? A sample (or at least instructions how to create such a file) would be useful either way.

comment:2 Changed 11 years ago by Jacek.Pliszka@…

  • Cc Jacek.Pliszka@… added

OK, but if it is moutned and we see it as a directory - is it possible to play it as DVD ?

comment:3 Changed 11 years ago by Jacek.Pliszka@…

OK, sorry, I answered myself - there is -dvd-device option...

Now all I need is to write a wrapper...

comment:4 Changed 11 years ago by Jacek.Pliszka@…

  • Cc Jacek.Pliszka@… removed

OK - sorry - I read the diocs and I should use -dvd-device.

So all I need is a wrapper - it first mounts it, then runs mplayer with -dvd-device - then unmounts.

comment:5 Changed 11 years ago by compn

out of curiosity, how do you mount isz ?

comment:6 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:7 Changed 8 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

Feature almost certainly won't be implemented in MPlayer (though I admit implementing in FFmpeg might be difficult since it has no CD/DVD support at all).

Note: See TracTickets for help on using tickets.