Opened 12 years ago

Closed 12 years ago

#820 closed defect (duplicate)

Theora in Matroska broken

Reported by: diego@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Try the sample from the URL, MPlayer cannot play the video stream, neither can ffplay. -demuxer lavf does not help either.

Playing /var/tmp/bugs/theora.mkv.
get_path('sub/') -> '/home/diego/.mplayer/sub/'
[file] File size is 10128128 bytes
STREAM: [file] /var/tmp/bugs/theora.mkv
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
[mkv] Found the head...
[mkv] + a segment...
[mkv] /---- [ parsing seek head ] ---------
[mkv] /---- [ parsing seek head ] ---------
[mkv] \---- [ parsing seek head ] ---------
[mkv] /---- [ parsing cues ] -----------
[mkv] \---- [ parsing cues ] -----------
[mkv] \---- [ parsing seek head ] ---------
[mkv] |+ segment information...
[mkv] | + timecode scale: 1000000
[mkv] | + duration: 6.382s
[mkv] |+ segment tracks...
[mkv] | + a track...
[mkv] | + Track number: 1
[mkv] | + Track type: Video
[mkv] | + Default flag: 1
[mkv] | + Codec ID: V_THEORA
[mkv] | + CodecPrivate?, length 2732
[mkv] | + Default duration: 41.708ms ( = 23.976 fps)
[mkv] | + Language: und
[mkv] | + Video track
[mkv] | + Pixel width: 1280
[mkv] | + Pixel height: 720
[mkv] | + Display width: 1280
[mkv] | + Display height: 720
[mkv] |+ found cluster, headers are parsed completely :)
[mkv] Unknown/unsupported CodecID (V_THEORA) or missing/bad CodecPrivate?
[mkv] data (track 1).
[mkv] Track ID 1: video (V_THEORA), -vid 0
[mkv] No video track found/wanted.
Matroska file format detected.
No stream found.

Change History (3)

comment:1 Changed 12 years ago by compn

works4me, latest svn.

D:\mplayer-testclips>mplaye theora.mkv -demuxer lavf
MPlayer dev-SVN-r23277-3.4.5 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) processor (Family: 6, Model: 4, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.
c:\winnt\fonts\comic.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: c:\winnt\fonts\comic.ttf

Playing theora.mkv.
libavformat file format detected.
[matroska @ 00A8CD98]Ignoring seekhead entry for ID=0x1549a966
[matroska @ 00A8CD98]Ignoring seekhead entry for ID=0x1654ae6b
[matroska @ 00A8CD98]Ignoring seekhead entry for ID=0x114d9b74
[matroska @ 00A8CD98]Unknown entry 0x73a4 in info header
[matroska @ 00A8CD98]Unknown track header entry 0x55aa - ignoring
[matroska @ 00A8CD98]Unknown track header entry 0x23314f - ignoring
[matroska @ 00A8CD98]Unknown track header entry 0x55ee - ignoring
[matroska @ 00A8CD98]Unknown track header entry 0xaa - ignoring
[theora @ 009F41D0]Theora bitstream version 30200
[theora @ 009F41D0]344 bits left in packet 81
[theora @ 009F41D0]7 bits left in packet 82
[lavf] Video stream found, -vid 0
VIDEO: [theo] 1280x720 0bpp 24.390 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[theora @ 009F41D0]Theora bitstream version 30200
[theora @ 009F41D0]344 bits left in packet 81
[theora @ 009F41D0]7 bits left in packet 82
Selected video codec: [fftheora] vfm: ffmpeg (FFmpeg Theora)
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [directx] 1280x720 => 1280x720 Planar YV12
[ASPECT] Warning: No suitable new res found!
V: 0.8 20/ 20 291% 105% 0.0% 0 0
Exiting... (Quit)

comment:2 Changed 12 years ago by diego@…

(In reply to comment #1)

works4me, latest svn.

D:\mplayer-testclips>mplaye theora.mkv -demuxer lavf

Yes, I bungled that test, it works with the libavformat demuxer.

comment:3 Changed 12 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

bungled a dupe too

* This bug has been marked as a duplicate of bug 695 *

Note: See TracTickets for help on using tickets.