Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#83 closed defect (worksforme)

Wrong colors with -vo xv on (some) Divx5 files

Reported by: bertola@… Owned by: reimar
Priority: normal Component: vo
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hello,

when playing some recent DivX5 files, e.g. this one
http://trailers.divx.com/Fox/Day_After_Tomorrow.avi

I get an image with totally messed up colors: it looks like the b/w image is
fine but the red, green, blue components (or maybe is hue/saturation, I am no
expert) are stretched out from top left to right bottom.

After trying out things I found that if I change the default -vo e.g.
-vo gl, then it works fine (but I lose aspect ratio in fullscreen mode)
and -vo x11 also works fine but it does not scale the image in fullscreen mode.
-vo sdl present similar misbehavior to -vo xv.

I have noticed this only on Divx5 files so far.
The same file and the same version of Mplayer work OK on another laptop (Sony
Vaio with nVidia geforce4).
Looking at the outputs of mplayer -V I have noticed that in the Vaio case
it says that "wm supports layers", whereas in the Toshiba case it does not say so.
Could it be the reason? (I am wildly guessing in my infinite ignorance)

I put below the output of mplayer -V file.
The hardware is a Toshiba Satellite with Fedora Core 1, the graphic card is a
82852/855GM Integrated Graphic Device, with driver "i810" (from the XFreeConfig)

MPlayer 1.0pre5-3.3.2 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 2395 MHz (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Reading config file /etc/mplayer/mplayer.confReading config file
/home/bertola/.mplayer/config
Reading /home/bertola/.mplayer/codecs.conf: Reading /etc/mplayer/codecs.conf:
Using built-in default codecs.conf.
CommandLine?: '-V' 'Day_After_Tomorrow.avi'
init_freetype
get_path('font/font.desc') -> '/home/bertola/.mplayer/font/font.desc'
font: can't open file: /home/bertola/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
get_path('input.conf') -> '/home/bertola/.mplayer/input.conf'
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Setting up LIRC support...
get_path('Day_After_Tomorrow.avi.conf') ->
'/home/bertola/.mplayer/Day_After_Tomorrow.avi.conf'

Playing Day_After_Tomorrow.avi.
[file] File size is 22962176 bytes
STREAM: [file] Day_After_Tomorrow.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
AVI file format detected.
list_end=0x2292
======= AVI Header =======
us/frame: 41708 (fps=23.976)
max bytes/sec: 0
padding: 0
MainAVIHeader.dwFlags: (272) HAS_INDEX IS_INTERLEAVED
frames total: 3381 initial: 0
streams: 2
Suggested BufferSize?: 0
Size: 628 x 344
==========================
list_end=0x10F4
==> Found video stream: 0

STREAM Header =====

Type: vids FCC: divx (78766964)
Flags: 0
Priority: 0 Language: 0
InitialFrames?: 0
Rate: 24000/1001 = 23.976
Start: 0 Len: 3381
Suggested BufferSize?: 111253
Quality 10000
Sample size: 0
==========================
found 'bih', 40 bytes of 40
======= VIDEO Format ======

biSize 40
biWidth 628
biHeight 344
biPlanes 1
biBitCount 24
biCompression 808802372='DX50'
biSizeImage 1296192

===========================
Regenerating keyframe table for DIVX 4 video
list_end=0x2186
==> Found audio stream: 1

STREAM Header =====

Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames?: 1
Rate: 11982/1 = 11982.000
Start: 0 Len: 1689574
Suggested BufferSize?: 6000
Quality -1
Sample size: 1
==========================
found 'wf', 30 bytes of 18
======= WAVE Format =======
Format Tag: 85 (0x55)
Channels: 2
Samplerate: 44100
avg byte/sec: 11982
Block align: 1
bits/sample: 0
cbSize: 12
mp3.wID=1
mp3.fdwFlags=0x2
mp3.nBlockSize=313
mp3.nFramesPerBlock=1
mp3.nCodecDelay=1393
===========================
list_end=0x2292
AVI: dmlh found (size=248) (total_frames=3381)
list_end=0x15CB89C
Found movie at 0x280C - 0x15CB89C
Reading INDEX block, 6751 chunks for 3381 frames (fpos=0x15cb8a4)
AVI index offset: 0x2808 (movi=0x280C idx0=0x4 idx1=0x177C)
Auto-selected AVI audio ID = 1
Auto-selected AVI video ID = 0
AVI: Searching for audio stream (id:1)
AVI video size=21098091 (3381) audio size=1689574 (1689574)
VIDEO: [DX50] 628x344 24bpp 23.976 fps 1196.9 kbps (146.1 kbyte/s)
[V] filefmt:3 fourcc:0x30355844 size:628x344 fps:23.98 ftime:=0.0417
get_path('sub/') -> '/home/bertola/.mplayer/sub/'
get_path('default.sub') -> '/home/bertola/.mplayer/default.sub'
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: made decode tables with MMX optimization
mp3lib: using MMX optimized decore!
MP3lib: init layer2&3 finished, tables done

MPEG 1.0, Layer III, 44100 Hz 96 kbit Joint-Stereo, BPF: 313
Channels: 2, copyright: No, original: Yes, CRC: No, emphasis: 0
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 12000->176400 (96.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Current fstype setting honours FULLSCREEN ABOVE BELOW X atoms
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000001 and bps = 2
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
ao2: 44100 Hz 2 chans Signed 16-bit (Little-Endian)
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: Signed 16-bit (Little-Endian) (requested: Signed
16-bit (Little-Endian))
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags: 4/4 (16384 bytes/frag) free: 65536
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000001 and bps = 2
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000001 and bps = 2
Starting playback...
[ffmpeg] aspect_ratio: 1.825581
VDec: vo config request - 628 x 344 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.83:1 - prescaling to correct movie aspect.
VO Config (628x344->628x344,flags=0,'MPlayer',0x32315659)
VO: [xv] 628x344 => 628x344 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x30323449 (I420) planar
Xvideo image format: 0x59565955 (UYVY) packed
using Xvideo port 60 for hw scaling
[xv] dx: 0 dy: 0 dw: 628 dh: 344
* [vo] Allocating (slices) mp_image_t, 640x352x12bpp YUV planar, 337920 bytes
[xv] dx: 0 dy: 0 dw: 628 dh: 344
A: 0.1 V: 0.0 A-V: 0.056 ct: 0.000 1/ 1 0% 0% 0.0% 0 0 0%
XXX initial v_pts=0.000 a_pos=6000 (0.501)
* [vo] Allocating (slices) mp_image_t, 640x352x12bpp YUV planar, 337920 bytes
A: 0.1 V: 0.0 A-V: 0.025 ct: 0.002 2/ 2 0% 0% 0.0% 0

Change History (5)

comment:1 Changed 15 years ago by reimar

  • Summary changed from Wrong colors with -vo xv on (some) Divx5 files to Wrong colors with -vo xv on (some) Divx5 files

I get an image with totally messed up colors: it looks like the b/w image is
fine but the red, green, blue components (or maybe is hue/saturation, I am no
expert) are stretched out from top left to right bottom.

Works for me. Try using CVS version, too.

After trying out things I found that if I change the default -vo e.g.
-vo gl, then it works fine (but I lose aspect ratio in fullscreen mode)

use -vo gl2 for that.

and -vo x11 also works fine but it does not scale the image in fullscreen mode.

use -zoom, but that is slow.

-vo sdl present similar misbehavior to -vo xv.

Might also try -vo vidix, -vo xvidix, -vo cvidix (if I remember correctly you
must either setup dhahelper or su root for that).
This might help to see if it's a bug in your graphics driver.

In addition using -vf format=... or -vf noformat=... might help.
(... being e.g. YV12, I420, IYUV, YUY2, UYVY)

Also the xvinfo output might provide some useful information.
I personally expect this to be a graphics driver bug...

comment:2 Changed 15 years ago by bertola@…

(In reply to comment #1)

use -vo gl2 for that.

No, has similar problems (even worse as also the bw picture is all slanted)

use -zoom, but that is slow.

Thnks, that worked but -as you say- is a backup solution.

Might also try -vo vidix, -vo xvidix, -vo cvidix (if I remember correctly you
must either setup dhahelper or su root for that).
This might help to see if it's a bug in your graphics driver.

In addition using -vf format=... or -vf noformat=... might help.
(... being e.g. YV12, I420, IYUV, YUY2, UYVY)

I will try, but my point is that mplayer should work "out of the box" (and
mostly does) at least for plain playback.

Also the xvinfo output might provide some useful information.
I personally expect this to be a graphics driver bug...

I also have this feeling: I have updated the driver (it is provided directly by
Intel) but did not solve the problem.

Thanks anyway.

comment:3 Changed 14 years ago by reimar

Id this bug still there in current CVS/pre6?

use -vo gl2 for that.

No, has similar problems (even worse as also the bw picture is all slanted)

There was a bug in gl2 that could cause problems with video where the width is
not divisible by 8 (fixed in pre6 and later). You might also try to expand to
e.g. width 632.

Might also try -vo vidix, -vo xvidix, -vo cvidix (if I remember correctly you
must either setup dhahelper or su root for that).
This might help to see if it's a bug in your graphics driver.

In addition using -vf format=... or -vf noformat=... might help.
(... being e.g. YV12, I420, IYUV, YUY2, UYVY)

I will try, but my point is that mplayer should work "out of the box" (and
mostly does) at least for plain playback.

No question about that, but I ask because I need more information to locate the bug.

Btw.: -vo gl now does aspect scaling and has a IMHO very nice OSD.

comment:4 Changed 13 years ago by diego@…

  • Owner changed from alex@… to Reimar.Doeffinger@…

Reimar, this bug report is so old that I assume that you can probably close it.

comment:5 Changed 13 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Not enough information available to fix and actually might already be fixed, if
it was a MPlayer bug at all, thus closing.

Note: See TracTickets for help on using tickets.