Opened 12 years ago

Closed 11 years ago

#952 closed defect (invalid)

Side buttons to modify PCM volume is broken

Reported by: hypeuser@… Owned by: reimar
Priority: normal Component: GUI
Version: 1.0rc2 Severity: normal
Keywords: Cc: hypeuser@…, bill@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

By default on mplayer 1rc1, sides buttons of my mouse did modify the volume.
On rc2, it's not working anymore.
Here is the output of gmplayer file.avi after i clicked on my sides buttons:

No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6_DBL'. 22 0 49%
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN6'.-MOUSE_BTN6_DBL
No bind found for key 'MOUSE_BTN5'.-MOUSE_BTN5_DBL
No bind found for key 'MOUSE_BTN5'.-MOUSE_BTN5_DBL
No bind found for key 'MOUSE_BTN5'.-MOUSE_BTN5_DBL
No bind found for key 'MOUSE_BTN5_DBL'. 22 0 49%
No bind found for key 'MOUSE_BTN5'.-MOUSE_BTN5_DBL
No bind found for key 'MOUSE_BTN5_DBL'. 22 0 49%
No bind found for key 'MOUSE_BTN5'.-MOUSE_BTN5_DBL

Change History (5)

comment:1 Changed 12 years ago by hypeuser@…

  • Cc hypeuser@… added

I tried to manually add:

MOUSE_BTN5 volume 5
MOUSE_BTN6 volume -5

to both /etc/mplayer/input.conf and ~/.mplayer/input.conf, with no effect (ie same error message appears)

Tho, when running gmplayer -v file.avi, to be sure that /etc/mplayer/input.conf and/or ~/.mplayer/input.conf were loaded, i noticed that mplayer was looking in :

"Reading /usr/etc/mplayer/input.conf: Can't open '/usr/etc/mplayer/input.conf': No such file or directory "

( i did manually remove ~/.mplayer/input.conf to be able to see this)

Where it should be looking in /etc/mplayer.

I used ./configure --enable-gui to build mplayer.

comment:2 Changed 12 years ago by hypeuser@…

Tried with svn mplayer rev 25234
Compiled using:
./configure --enable-largefiles --enable-gui --codecsdir=/usr/local/lib/codecs

Same error.

comment:3 Changed 12 years ago by compn

use --confdir=/etc/

comment:4 Changed 11 years ago by bill@…

  • Cc bill@… added

confirmed as of MPlayer dev-SVN-r27415-4.2.3
Ubuntu 7.1 comes with mplayer 1rc1 and
MOUSE_BTN0 seek -10
MOUSE_BTN2 seek +30
works PERFECT for commercial skipping as it responds to mouse clicks as fast as a person can click

Ubuntu 8.04 comes with mplayer 1rc2 mouse still works but you have to wait between clicks
No bind found for key 'MOUSE_BTN2'.-MOUSE_BTN2_DBL
is error message and tried building with --confdir=/etc/ no joy
tried regression but can only go back a few months before ./configure starts erroring out.
confirmed this behaviour on Intel and AMD CPU's

comment:5 Changed 11 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

This is a side-effect of adding generic (OS-independent) double-click support.
You can either bind MOUSE_BTN5_DBL and MOUSE_BTN6_DBL or the others the messages tell you or disable double-click support (-doubleclick-time 0).
Check the man page for details and reopen if you still think some behaviour is not as intended (setting to invalid because I think MPlayer is behaving as it is supposed to, even though it complicates things for you).

Note: See TracTickets for help on using tickets.