Opened 6 years ago

Closed 5 years ago

#2172 closed defect (fixed)

dvdnav:// don't work with some dvds.

Reported by: tanahqua Owned by: reimar
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

dvdnav:// exits with error message.

MPEG: Missing video stream!? Contact the author, it may be a bug :(
dvdnav_stream, seeking to 0 failed: Cannot seek in a still frame.

if revert r36543(Only detect a file as MPEG-PS if we can find at least 2 packets.) in libmpdemux/demux_mpg.c, play without problem.

Attachments (1)

dvdnav.log (8.0 KB) - added by tanahqua 6 years ago.
full output with -v

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by reimar

Can you give the full output? It should at least fall back to libavformat still after that. (that is bug #1)
Bug #2 is that for DVDNAV (and DVDs in general) we should rather just force the demuxer instead of running auto-detection, it just needlessly slows things down.
Fixing these two things I think is preferable over reverting (or even just fixing for still images) that change.

comment:2 Changed 6 years ago by reimar

  • Status changed from new to open

comment:3 Changed 6 years ago by reimar

  • Owner set to reimar

Changed 6 years ago by tanahqua

full output with -v

comment:4 Changed 5 years ago by 4Selur@…

Seems like I ran into the same problem.

using MPlayer SVN-r36775-4.8.2 and MEncoder SVN-r36775-4.8.2

no matter if I call:

mencoder -ovc raw -noskip -forcedsubsonly -nosub -nosound -mc 0 -lavdopts threads=8 -of rawvideo -o NUL -dvd-device "F:\TestClips&Co\DVDs\ElephantsDream" dvd://1

or

mplayer -lavdopts threads=1  -aspect 1.77778:1 -mc 0 -nosound -nomouseinput -nokeepaspect -monitorpixelaspect 1 dvd://1 -dvd-device "F:\TestClips&Co\DVDs\ElephantsDream\VIDEO_TS" -forcedsubsonly -nosub -noautosub -fps 25 -vo direct3d

I get:

MPEG: Missing video stream!? Contact the author, it may be a bug :(

the mencoder call returns:

MEncoder SVN-r36775-4.8.2 (C) 2000-2014 MPlayer Team
libdvdread: Could not open F:\TestClips&Co\DVDs\ElephantsDream with libdvdcss.
libdvdread: Can't open F:\TestClips&Co\DVDs\ElephantsDream for reading
libdvdread: Device F:\TestClips&Co\DVDs\ElephantsDream inaccessible, CSS authent
ication not available.
There are 1 titles on this DVD.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (5.1) language: en aid: 128.
number of audio channels on disk: 1.
subtitle ( sid ): 0 language: en
subtitle ( sid ): 0 language: en
number of subtitles on disk: 2

success: format: 2  data: 0x0 - 0x20804800
MPEG: Missing video stream!? Contact the author, it may be a bug :(
============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.

and the mplayer call returns:

MPlayer SVN-r36775-4.8.2 (C) 2000-2014 MPlayer Team

Playing dvd://1.
libdvdread: Could not open F:\TestClips&Co\DVDs\ElephantsDream\VIDEO_TS with lib
dvdcss.
libdvdread: Can't open F:\TestClips&Co\DVDs\ElephantsDream\VIDEO_TS for reading
libdvdread: Device F:\TestClips&Co\DVDs\ElephantsDream\VIDEO_TS inaccessible, CS
S authentication not available.
There are 1 titles on this DVD.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (5.1) language: en aid: 128.
number of audio channels on disk: 1.
subtitle ( sid ): 0 language: en
subtitle ( sid ): 0 language: en
number of subtitles on disk: 2

MPEG: Missing video stream!? Contact the author, it may be a bug :(


Exiting... (End of file)

mplayer&mencoder were build using: https://github.com/jb-alvarado/media-autobuild_suite

This happens for me with every DVD.

Last edited 5 years ago by 4Selur@… (previous) (diff)

comment:5 Changed 5 years ago by 4Selur@…

think I found the problem if I use:

mplayer dvd://1 -dvd-device "f:\TestClips&Co\DVDs\ElephantsDream" -vo direct3d

the input is handled fine
if I add '-nosound'

mplayer -nosound dvd://1 -dvd-device "f:\TestClips&Co\DVDs\ElephantsDream" -vo direct3d

I get:

MPEG: Missing video stream!? Contact the author, it may be a bug :(

Same happens for mencoder, as soon as '-nosound' is present DVD handling fails.

Last edited 5 years ago by 4Selur@… (previous) (diff)

comment:6 Changed 5 years ago by 4Selur@…

a workaround for my problem seems to be to replace all all occurrences of 'dvd://' where '-nosound' is used with '-demuxer lavf dvdnav://'

---
still this is a bug which should be fixed

Last edited 5 years ago by 4Selur@… (previous) (diff)

comment:7 Changed 5 years ago by reimar

  • Resolution set to fixed
  • Status changed from open to closed

Somehow I do not get email notifications, sorry for the delay.
Was fixed recently in r36845. Was probably broken in r36543.

Note: See TracTickets for help on using tickets.