Opened 4 years ago

Closed 4 years ago

#2332 closed defect (fixed)

Crash when seeking audio files

Reported by: redxii Owned by: beastd
Priority: normal Component: undetermined
Version: HEAD Severity: critical
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: yes Analyzed by developer: yes

Description

All audio types seem to be affected, including Audio CDs, they play fine but when seeking will trigger signal 11 in 'unknown'. Video files aren't affected.

A really short flac sample is included.

Attachments (2)

gdb.log (12.1 KB ) - added by redxii 4 years ago.
config.mak (55.2 KB ) - added by redxii 4 years ago.
Configuration

Download all attachments as: .zip

Change History (9)

comment:1 by redxii, 4 years ago

Just the gdb log attached, no sample.

The gdb probably makes zero sense (at least to me), it seems to reference 'mono9_data' (libcaca) but disabling libcaca just changes it to something else.

Last edited 4 years ago by redxii (previous) (diff)

by redxii, 4 years ago

Attachment: gdb.log added

by redxii, 4 years ago

Attachment: config.mak added

Configuration

comment:2 by beastd, 4 years ago

Reproduced by developer: set
Status: newopen

Reproduced.

comment:3 by beastd, 4 years ago

Cc: reimar added

comment:4 by beastd, 4 years ago

Regression since SVN r37953 .

comment:5 by beastd, 4 years ago

Following patch fixes the problem here:

--- a/mplayer.c
+++ b/mplayer.c
@@ -4034,7 +4034,7 @@ goto_enable_cache:
                 }
 
                 // reset last frame marker
-                if (mpctx->sh_video->frametime < 0)
+                if (mpctx->sh_video && mpctx->sh_video->frametime < 0)
                     mpctx->sh_video->frametime = 1.0f / mpctx->sh_video->fps;
                 rel_seek_secs = 0;
                 abs_seek_pos  = 0;

in reply to:  5 comment:6 by redxii, 4 years ago

Fix confirmed for me, thanks.

comment:7 by beastd, 4 years ago

Analyzed by developer: set
Resolution: fixed
Status: openclosed

Committed the suggested patch.

Thank you for the report and confirming the fix!

Note: See TracTickets for help on using tickets.